1 | %define gettext_package gnome-panel-2.0 |
---|
2 | |
---|
3 | %define glib2_version 2.0.0 |
---|
4 | %define gtk2_version 2.1.2 |
---|
5 | %define libglade2_version 2.0.0 |
---|
6 | %define libgnome_version 2.1.1 |
---|
7 | %define libgnomeui_version 2.1.2 |
---|
8 | %define gnome_desktop_version 2.0.3 |
---|
9 | %define libwnck_version 2.1.0 |
---|
10 | %define libbonobo_version 2.0.0 |
---|
11 | %define libbonoboui_version 2.0.0 |
---|
12 | %define gnome_vfs2_version 2.0.2 |
---|
13 | %define bonobo_activation_version 1.0.0 |
---|
14 | %define libxslt_version 1.0.17 |
---|
15 | |
---|
16 | Summary: GNOME panel |
---|
17 | Name: gnome-panel |
---|
18 | Version: 2.8.3 |
---|
19 | Release: 1 |
---|
20 | URL: http://www.gnome.org |
---|
21 | Source0: ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/gnome-panel/%{name}-%{version}.tar.gz |
---|
22 | License: GPL |
---|
23 | Group: User Interface/Desktops |
---|
24 | BuildRoot: %{_tmppath}/%{name}-root |
---|
25 | |
---|
26 | Requires: gnome-desktop >= %{gnome_desktop_version} |
---|
27 | Prereq: /bin/awk, /bin/cat, /bin/ln, /bin/rm |
---|
28 | |
---|
29 | BuildRequires: glib2-devel >= %{glib2_version} |
---|
30 | BuildRequires: gtk2-devel >= %{gtk2_version} |
---|
31 | BuildRequires: libglade2-devel >= %{libglade2_version} |
---|
32 | BuildRequires: libgnome-devel >= %{libgnome_version} |
---|
33 | BuildRequires: libgnomeui-devel >= %{libgnomeui_version} |
---|
34 | BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version} |
---|
35 | BuildRequires: libwnck-devel >= %{libwnck_version} |
---|
36 | BuildRequires: libbonobo-devel >= %{libbonobo_version} |
---|
37 | BuildRequires: libbonoboui-devel >= %{libbonoboui_version} |
---|
38 | BuildRequires: gnome-vfs2-devel >= %{gnome_vfs2_version} |
---|
39 | BuildRequires: bonobo-activation-devel >= %{bonobo_activation_version} |
---|
40 | BuildRequires: libxslt-devel >= %{libxslt_version} |
---|
41 | BuildRequires: Xft |
---|
42 | BuildRequires: fontconfig |
---|
43 | |
---|
44 | %description |
---|
45 | |
---|
46 | The GNOME panel provides the window list, workspace switcher, menus, and other |
---|
47 | features for the GNOME desktop. |
---|
48 | |
---|
49 | %prep |
---|
50 | %setup -q |
---|
51 | |
---|
52 | %build |
---|
53 | |
---|
54 | %configure |
---|
55 | make |
---|
56 | |
---|
57 | %install |
---|
58 | rm -rf $RPM_BUILD_ROOT |
---|
59 | |
---|
60 | export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 |
---|
61 | %makeinstall |
---|
62 | unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL |
---|
63 | |
---|
64 | ## blow away stuff we don't want |
---|
65 | /bin/rm -rf $RPM_BUILD_ROOT/var/scrollkeeper |
---|
66 | rmdir --ignore-fail-on-non-empty $RPM_BUILD_ROOT/var |
---|
67 | /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libpanel-applet-2.a |
---|
68 | /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libpanel-applet-2.la |
---|
69 | /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libgen_util_applet-2.a |
---|
70 | /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libgen_util_applet-2.la |
---|
71 | /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-panel/libnotification-area-applet.a |
---|
72 | /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-panel/libnotification-area-applet.la |
---|
73 | |
---|
74 | %find_lang %{gettext_package} |
---|
75 | grep -q '/usr/share/locale' %{gettext_package}.lang || exit 1 |
---|
76 | |
---|
77 | %clean |
---|
78 | rm -rf $RPM_BUILD_ROOT |
---|
79 | |
---|
80 | %post |
---|
81 | export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` |
---|
82 | # this spits a warning right now, needs fixing in gconf |
---|
83 | gconftool-2 --direct --config-source=$GCONF_CONFIG_SOURCE --recursive-unset /schemas/apps/panel |
---|
84 | SCHEMAS="panel-global-config.schemas panel-per-panel-config.schemas mailcheck.schemas pager.schemas tasklist.schemas clock.schemas fish.schemas" |
---|
85 | for S in $SCHEMAS; do |
---|
86 | gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null |
---|
87 | done |
---|
88 | /sbin/ldconfig |
---|
89 | |
---|
90 | %postun |
---|
91 | if [ "$1" = "0" ]; then |
---|
92 | rm -f ${_sysconfdir}/gconf/schemas/panel-per-panel-config.schemas |
---|
93 | fi |
---|
94 | /sbin/ldconfig |
---|
95 | |
---|
96 | %files -f %{gettext_package}.lang |
---|
97 | %defattr(-,root,root) |
---|
98 | |
---|
99 | %doc AUTHORS COPYING ChangeLog NEWS README |
---|
100 | |
---|
101 | %{_datadir}/pixmaps |
---|
102 | %{_datadir}/gnome |
---|
103 | %{_datadir}/gnome-panelrc |
---|
104 | %{_datadir}/control-center-2.0 |
---|
105 | %{_datadir}/idl |
---|
106 | %{_datadir}/gnome-2.0 |
---|
107 | %{_datadir}/gnome-panel |
---|
108 | %{_datadir}/gen_util |
---|
109 | %{_datadir}/gtk-doc |
---|
110 | %{_datadir}/omf |
---|
111 | %{_datadir}/man/man*/* |
---|
112 | %{_bindir}/* |
---|
113 | %{_libexecdir}/* |
---|
114 | %{_libdir}/bonobo |
---|
115 | %{_libdir}/*.so.* |
---|
116 | %{_sysconfdir}/gconf/schemas/*.schemas |
---|
117 | %{_sysconfdir}/sound |
---|
118 | |
---|
119 | # theoretically a devel package, but just doesn't seem worth it |
---|
120 | %{_libdir}/pkgconfig/* |
---|
121 | %{_includedir}/panel-2.0 |
---|
122 | %{_libdir}/*.so |
---|
123 | %{_libdir}/gnome-panel/libnotification-area-applet.so |
---|
124 | |
---|
125 | |
---|
126 | %changelog |
---|
127 | * Sun Nov 10 2002 Christian F.K. Schaller <Uraeus@gnome.org> |
---|
128 | - Initial update of CVS version based on RH one |
---|
129 | |
---|