1 | # Note that this is NOT a relocatable package |
---|
2 | %define name gnome-vfs |
---|
3 | %define ver 1.0.5 |
---|
4 | %define RELEASE 1 |
---|
5 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
6 | %define prefix /usr |
---|
7 | %define sysconfdir /etc |
---|
8 | |
---|
9 | Summary: The GNOME virtual file-system libraries |
---|
10 | Name: %name |
---|
11 | Version: %ver |
---|
12 | Release: %rel |
---|
13 | Vendor: CVS |
---|
14 | Distribution: GNOME |
---|
15 | Copyright: LGPL |
---|
16 | Group: System Environment/Libraries |
---|
17 | Source: ftp://ftp.gnome.org/pub/GNOME/sources/%name/%name-%{ver}.tar.gz |
---|
18 | URL: http://www.gnome.org/ |
---|
19 | BuildRoot: /var/tmp/%{name}-root |
---|
20 | Requires: glib >= 1.2.6 |
---|
21 | Requires: GConf >= 0.9 |
---|
22 | Requires: oaf >= 0.3.0 |
---|
23 | Docdir: %{prefix}/doc |
---|
24 | Summary: GNOME VFS is the GNOME virtual file system. It is used extensively by Nautilus. |
---|
25 | |
---|
26 | %description |
---|
27 | GNOME VFS is the GNOME virtual file system. It is the foundation of the |
---|
28 | Nautilus file manager. It provides a modular architecture and ships with |
---|
29 | several modules that implement support for file systems, http, ftp and others. |
---|
30 | It provides a URI-based API, a backend supporting asynchronous file operations, |
---|
31 | a MIME type manipulation library and other features. |
---|
32 | |
---|
33 | %package devel |
---|
34 | Summary: Libraries and include files for developing GNOME VFS applications. |
---|
35 | Group: Development/Libraries |
---|
36 | Requires: %name = %{PACKAGE_VERSION} |
---|
37 | Requires: GConf-devel |
---|
38 | Requires: oaf-devel |
---|
39 | |
---|
40 | %description devel |
---|
41 | This package provides the necessary development libraries for writing |
---|
42 | GNOME VFS modules and applications that use the GNOME VFS APIs. |
---|
43 | |
---|
44 | %changelog |
---|
45 | * Tue Feb 22 2000 Ross Golder <rossigee@bigfoot.com> |
---|
46 | - Integrate into source tree |
---|
47 | |
---|
48 | %prep |
---|
49 | %setup -q |
---|
50 | |
---|
51 | %build |
---|
52 | %ifarch alpha |
---|
53 | MYARCH_FLAGS="--host=alpha-redhat-linux" |
---|
54 | %endif |
---|
55 | # Needed for snapshot releases. |
---|
56 | MYCFLAGS="$RPM_OPT_FLAGS" |
---|
57 | if [ ! -f configure ]; then |
---|
58 | CFLAGS="$MYCFLAGS" ./autogen.sh $MYARCH_FLAGS --enable-more-warnings --prefix=%prefix --localstatedir=/var/lib --sysconfdir=%{sysconfdir} |
---|
59 | else |
---|
60 | CFLAGS="$MYCFLAGS" ./configure $MYARCH_FLAGS --enable-more-warnings --prefix=%prefix --localstatedir=/var/lib --sysconfdir=%{sysconfdir} |
---|
61 | fi |
---|
62 | make -k |
---|
63 | |
---|
64 | %install |
---|
65 | rm -rf $RPM_BUILD_ROOT |
---|
66 | make -k sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} prefix=$RPM_BUILD_ROOT%{prefix} install |
---|
67 | |
---|
68 | %clean |
---|
69 | rm -rf $RPM_BUILD_ROOT |
---|
70 | |
---|
71 | %post |
---|
72 | if ! grep %{prefix}/lib /etc/ld.so.conf > /dev/null ; then |
---|
73 | echo "%{prefix}/lib" >> /etc/ld.so.conf |
---|
74 | fi |
---|
75 | /sbin/ldconfig |
---|
76 | |
---|
77 | %postun -p /sbin/ldconfig |
---|
78 | |
---|
79 | %files |
---|
80 | %defattr(-, root, root) |
---|
81 | |
---|
82 | %doc AUTHORS COPYING ChangeLog NEWS README |
---|
83 | %config %{sysconfdir}/vfs/modules/*.conf |
---|
84 | %{prefix}/lib/*.0 |
---|
85 | %{prefix}/lib/*.sh |
---|
86 | %{prefix}/lib/*.so |
---|
87 | %{prefix}/lib/vfs/extfs/* |
---|
88 | %{prefix}/lib/vfs/modules/*.so |
---|
89 | %{prefix}/share/application-registry/gnome-vfs.applications |
---|
90 | %{prefix}/share/locale/*/LC_MESSAGES/*.mo |
---|
91 | |
---|
92 | %files devel |
---|
93 | %defattr(-, root, root) |
---|
94 | %{prefix}/include/gnome-vfs-1.0/libgnomevfs/*.h |
---|
95 | %{prefix}/lib/gnome-vfs-1.0/include/*.h |
---|
96 | %{prefix}/lib/*.a |
---|
97 | %{prefix}/lib/*.la |
---|
98 | %{prefix}/bin/gnome-vfs-config |
---|