source: trunk/third/gtk/gtk+.spec @ 17071

Revision 17071, 3.8 KB checked in by ghudson, 23 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r17070, which included commits to RCS files with non-trunk default branches.
Line 
1# Note that this is NOT a relocatable package
2%define ver      1.2.10
3%define  RELEASE 1
4%define  rel     %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
5%define prefix   /usr
6
7Summary: The Gimp Toolkit
8Name: gtk+
9Version: %ver
10Release: %rel
11Copyright: LGPL
12Group: X11/Libraries
13Source: ftp://ftp.gimp.org/pub/gtk/v1.1/gtk+-%{ver}.tar.gz
14BuildRoot: /var/tmp/gtk-%{PACKAGE_VERSION}-root
15Obsoletes: gtk
16Packager: Christopher Blizzard <blizzard@redhat.com>
17URL: http://www.gtk.org
18Prereq: /sbin/install-info
19Requires: glib
20Docdir: %{prefix}/doc
21
22%description
23The X libraries originally written for the GIMP, which are now used by
24several other programs as well.
25
26%package devel
27Summary: GIMP Toolkit and GIMP Drawing Kit
28Group: X11/Libraries
29Requires: gtk+
30Obsoletes: gtk-devel
31PreReq: /sbin/install-info
32
33%description devel
34Static libraries and header files for the GIMP's X libraries, which are
35available as public libraries.  GLIB includes generally useful data
36structures, GDK is a drawing toolkit which provides a thin layer over
37Xlib to help automate things like dealing with different color depths,
38and GTK is a widget set for creating user interfaces.
39
40%changelog
41* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
42- updated spec file
43
44* Sun Oct 25 1998 Shawn T. Amundson <amundson@gtk.org>
45
46- Fixed Source: to point to v1.1
47
48* Tue Aug 04 1998 Michael Fulbright <msf@redhat.com>
49
50- change %postun to %preun
51
52* Mon Jun 27 1998 Shawn T. Amundson
53
54- Changed version to 1.1.0
55
56* Thu Jun 11 1998 Dick Porter <dick@cymru.net>
57
58- Removed glib, since it is its own module now
59
60* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
61
62- Split out glib package
63
64* Tue Apr  8 1998 Shawn T. Amundson <amundson@gtk.org>
65
66- Changed version to 1.0.0
67
68* Tue Apr  7 1998 Owen Taylor <otaylor@gtk.org>
69
70- Changed version to 0.99.10
71
72* Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
73
74- Changed version to 0.99.9
75- Changed gtk home page to www.gtk.org
76
77* Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
78
79- Changed version to 0.99.8
80
81* Sun Mar 15 1998 Marc Ewing <marc@redhat.com>
82
83- Added aclocal and bin stuff to file list.
84
85- Added -k to the SMP make line.
86
87- Added lib/glib to file list.
88
89* Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
90
91- Changed version to 0.99.7
92
93* Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
94
95- Updated ftp url and changed version to 0.99.6
96
97* Thu Mar 12 1998 Marc Ewing <marc@redhat.com>
98
99- Reworked to integrate into gtk+ source tree
100
101- Truncated ChangeLog.  Previous Authors:
102  Trond Eivind Glomsrod <teg@pvv.ntnu.no>
103  Michael K. Johnson <johnsonm@redhat.com>
104  Otto Hammersmith <otto@redhat.com>
105 
106%prep
107%setup
108
109%build
110# Needed for snapshot releases.
111if [ ! -f configure ]; then
112  CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix
113else
114  CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
115fi
116
117if [ "$SMP" != "" ]; then
118  (make "MAKE=make -k -j $SMP"; exit 0)
119  make
120else
121  make
122fi
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127make prefix=$RPM_BUILD_ROOT%{prefix} install
128
129gzip -9n $RPM_BUILD_ROOT%{prefix}/info/*
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post devel
139/sbin/install-info %{prefix}/info/gdk.info.gz %{prefix}/info/dir
140/sbin/install-info %{prefix}/info/gtk.info.gz %{prefix}/info/dir
141
142%preun devel
143if [ $1 = 0 ]; then
144    /sbin/install-info --delete %{prefix}/info/gdk.info.gz %{prefix}/info/dir
145    /sbin/install-info --delete %{prefix}/info/gtk.info.gz %{prefix}/info/dir
146fi
147
148%files
149%defattr(-, root, root)
150
151%doc AUTHORS COPYING ChangeLog NEWS README TODO
152%{prefix}/lib/libgtk-1.2.so.*
153%{prefix}/lib/libgdk-1.2.so.*
154%{prefix}/share/themes/Default
155%{prefix}/share/locale/*/*/*
156 
157
158%files devel
159%defattr(-, root, root)
160
161%{prefix}/lib/lib*.so
162%{prefix}/lib/*a
163%{prefix}/include/*
164%{prefix}/info/*
165%{prefix}/man/man1/*
166%{prefix}/share/aclocal/*
167%{prefix}/bin/*
Note: See TracBrowser for help on using the repository browser.