source: trunk/third/gtkhtml/gtkhtml.spec @ 19188

Revision 19188, 2.8 KB checked in by ghudson, 22 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r19187, which included commits to RCS files with non-trunk default branches.
RevLine 
[19187]1%define ver      1.1.9
[16766]2
3Summary: gtkhtml library
4Name: gtkhtml
5Version: %ver
6Release: 1
7Copyright: LGPL
8Group: X11/Libraries
9Source: ftp://ftp.gnome.org/pub/GNOME/sources/gtkhtml/gtkhtml-%{ver}.tar.gz
10BuildRoot: /var/tmp/gtkhtml-%{PACKAGE_VERSION}-root
11Provides: gtkhtml.so.0
12Requires: gnome-print >= 0.25
13Requires: gdk-pixbuf >= 0.8.0
14Requires: gal >= 0.7.99.5
15Requires: pspell
16Requires: bonobo >= 0.32
17Requires: GConf >= 0.9
18Requires: libghttp >= 1.0
19Requires: libglade
20
21%description
22This is GtkHTML, a lightweight HTML rendering/printing/editing engine.
23It was originally based on KHTMLW, but is now being developed
24independently of it.
25
26%package devel
27Summary: Libraries, includes, etc to develop gtkhtml applications
28Group: X11/libraries
29Requires: gtkhtml
30
31%description devel
32Libraries, include files, etc you can use to develop gtkhtml applications.
33
34
35
36
37%prep
38%setup -q
39
40%build
41# Needed for snapshot releases.
42if [ ! -f configure ]; then
43%ifarch alpha
44  CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --host=alpha-redhat-linux --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --with-bonobo
45%else
46  CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --with-bonobo
47%endif
48else
49%ifarch alpha
50  CFLAGS="$RPM_OPT_FLAGS" ./configure --host=alpha-redhat-linux --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --with-bonobo
51%else
52  CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --with-bonobo
53%endif
54fi
55
56if [ "$SMP" != "" ]; then
57  (make "MAKE=make -k -j $SMP"; exit 0)
58  make
59else
60  make
61fi
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66# Note how DESTDIR is passed. Using prefix=$RPM_BUILD_ROOT%{_prefix} instaead
67# nearly worked, but problems occured for /etc/CORBA/servers, where prefix
68# was ignored completely.
69make -k DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} localedir=$RPM_BUILD_ROOT%{_datadir}/locale install
70
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%post -p /sbin/ldconfig
76
77%postun -p /sbin/ldconfig
78
79%files
80%defattr(-, root, root)
81%doc AUTHORS ChangeLog NEWS README COPYING TODO
82%doc %{_datadir}/gnome/html/*
83%config %{_sysconfdir}/CORBA/servers/*.gnorba
84%{_bindir}/gtkhtml-properties-capplet
85%{_bindir}/gnome-gtkhtml-editor
86%{_bindir}/ebrowser
87%{_libdir}/*.so.*
88%{_libdir}/bonobo/plugin/*so
89%{_datadir}/control-center/Documents/*.desktop
90%{_datadir}/control-center/capplets/*.desktop
91%{_datadir}/gnome/apps/Settings/Documents/*.desktop
92%{_datadir}/gnome/ui/GNOME_GtkHTML_Editor.xml
93%dir %{_datadir}/gtkhtml
94%{_datadir}/gtkhtml/keybindingsrc.*
95%{_datadir}/gtkhtml/*.idl
96%{_datadir}/gtkhtml/*.glade
97%{_datadir}/gtkhtml/icons
98%{_datadir}/oaf/*.oaf
99%{_datadir}/locale/*/LC_MESSAGES/*.mo
100
101%files devel
102%defattr(-, root, root)
103%dir %{_includedir}/gtkhtml
104%{_includedir}/gtkhtml/*.h
105%{_libdir}/*.sh
106%{_libdir}/*.so
107%{_libdir}/*.a
108%{_libdir}/*.la
109#%{_libdir}/bonobo/plugin/*.a
110#%{_libdir}/bonobo/plugin/*.la
Note: See TracBrowser for help on using the repository browser.