source: trunk/third/libIDL/libIDL.spec @ 21474

Revision 21474, 1.9 KB checked in by ghudson, 20 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r21473, which included commits to RCS files with non-trunk default branches.
Line 
1%define version 0.8.5
2%define release SNAP
3
4Summary:   IDL parsing library
5Name:      libIDL
6Version:   %{version}
7Release:   %{release}
8Source:    %{name}-%PACKAGE_VERSION.tar.gz
9Vendor:    Andrew T. Veliath <andrewtv@usa.net>
10Copyright: LGPL
11Group:     Libraries
12Prereq:    /sbin/install-info
13Prefix:    /usr
14Docdir:    %prefix/doc
15BuildRoot: /var/tmp/%{name}-%{version}-root
16
17%changelog
18* Fri Oct 12 2001 Ross Golder <ross@golder.org>
19- Updated filenames and paths for libIDL2
20* Mon Sep 24 2001 Mark McLoughlin <mark@skynet.ie>
21- use LIBIDL_VERSION instead of LIBIDL_LIBRARY_VERSION
22* Fri Nov 28 1998 Andrew T. Veliath <andrewtv@usa.net>
23- Initial version
24
25%description
26libIDL is a small library for creating parse trees of CORBA v2.2
27compliant Interface Definition Language (IDL) files, which is a
28specification for defining interfaces which can be used between
29different CORBA implementations.
30
31%package devel
32Summary:  Header files and libraries needed for libIDL development
33Group:    Development/Libraries
34Requires: %{name} = %{version}
35
36%description devel
37This package includes the header files and libraries needed for
38developing programs using libIDL.
39
40%prep
41%setup
42
43%build
44CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr
45make
46
47%install
48rm -rf $RPM_BUILD_ROOT
49make install prefix=$RPM_BUILD_ROOT/%prefix
50gzip -9 $RPM_BUILD_ROOT/%prefix/info/*.info
51
52%post   -p /sbin/ldconfig
53%postun -p /sbin/ldconfig
54
55%post devel
56/sbin/install-info %prefix/info/libIDL2.info.gz %prefix/info/dir
57
58%preun devel
59if [ $1 = 0 ]; then
60        /sbin/install-info --delete %prefix/info/libIDL2.info.gz %prefix/info/dir
61fi
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(-,root,root)
68%doc COPYING ChangeLog AUTHORS
69%doc README* NEWS BUGS tstidl.c
70%prefix/lib/lib*.so.*.*
71
72%files devel
73%defattr(-,root,root)
74%prefix/bin/libIDL-config-2
75#%prefix/lib/*.sh
76%prefix/lib/pkgconfig/*.pc
77%prefix/lib/lib*.a
78%prefix/lib/lib*.so
79%prefix/info/libIDL2.info.gz
80%prefix/include/libIDL-2.0/libIDL/*.h
81#%prefix/share/aclocal/*
Note: See TracBrowser for help on using the repository browser.