Revision 20386,
1.7 KB
checked in by amb, 21 years ago
(diff) |
This commit was generated by cvs2svn to compensate for changes in r20385,
which included commits to RCS files with non-trunk default branches.
|
Line | |
---|
1 | %define debug_package %{nil} |
---|
2 | |
---|
3 | Summary: lightweight C library which eases the writing of UNIX daemons. |
---|
4 | Name: libdaemon |
---|
5 | Version: 0.6 |
---|
6 | Release: 1 |
---|
7 | URL: http://www.stud.uni-hamburg.de/users/lennart/projects/libdaemon |
---|
8 | Source: %{name}-%{version}.tar.gz |
---|
9 | License: GPL |
---|
10 | Group: System Environment/Libraries |
---|
11 | BuildRoot: %{_tmppath}/%{name}-%{version}-root |
---|
12 | |
---|
13 | %description |
---|
14 | libdaemon is a lightweight C library which eases the writing of UNIX daemons. |
---|
15 | It consists of the following parts: |
---|
16 | |
---|
17 | * A wrapper around fork() which does the correct daemonization |
---|
18 | procedure of a process |
---|
19 | * A wrapper around syslog() for simpler and compatible log output to |
---|
20 | Syslog or STDERR |
---|
21 | * An API for writing PID files |
---|
22 | * An API for serializing UNIX signals into a pipe for usage with |
---|
23 | select() or poll() |
---|
24 | |
---|
25 | Routines like these are included in most of the daemon software available. It |
---|
26 | is not that simple to get it done right and code duplication cannot be a goal. |
---|
27 | |
---|
28 | %package devel |
---|
29 | Summary: Static libraries and header files for libdaemon development. |
---|
30 | Group: Development/Libraries |
---|
31 | Requires: libdaemon = %{version} |
---|
32 | |
---|
33 | %description devel |
---|
34 | |
---|
35 | The libdaemon-devel package contains the header files and static libraries |
---|
36 | necessary for developing programs using libdaemon. |
---|
37 | |
---|
38 | %prep |
---|
39 | %setup -q |
---|
40 | |
---|
41 | %build |
---|
42 | %configure |
---|
43 | make |
---|
44 | |
---|
45 | %install |
---|
46 | %makeinstall |
---|
47 | |
---|
48 | %post -p /sbin/ldconfig |
---|
49 | |
---|
50 | %postun -p /sbin/ldconfig |
---|
51 | |
---|
52 | %clean |
---|
53 | rm -rf $RPM_BUILD_ROOT |
---|
54 | |
---|
55 | %files |
---|
56 | %defattr(-,root,root) |
---|
57 | %doc LICENSE README |
---|
58 | %{_libdir}/*so.* |
---|
59 | %{_libdir}/*.la |
---|
60 | |
---|
61 | %files devel |
---|
62 | %defattr(-,root,root) |
---|
63 | %doc LICENSE README |
---|
64 | %doc doc/* |
---|
65 | %{_includedir}/* |
---|
66 | %{_libdir}/*.a |
---|
67 | %{_libdir}/*.so |
---|
68 | %{_libdir}/pkgconfig/*.pc |
---|
69 | |
---|
70 | %changelog |
---|
71 | * Mon Jul 21 2003 Lennart Poettering 0.3 |
---|
72 | - fixes |
---|
73 | * Wed Jul 16 2003 Diego Santa Cruz <Diego.SantaCruz@epfl.ch> 0.2 |
---|
74 | - initial RPM |
---|
Note: See
TracBrowser
for help on using the repository browser.