1 | # Note that this is NOT a relocatable package |
---|
2 | %define ver 2.0.0 |
---|
3 | %define RELEASE SNAP |
---|
4 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
5 | %define prefix /usr |
---|
6 | |
---|
7 | Summary: LibGTop library |
---|
8 | Name: libgtop |
---|
9 | Version: %ver |
---|
10 | Release: %rel |
---|
11 | Copyright: LGPL |
---|
12 | Group: X11/Libraries |
---|
13 | Source: ftp://ftp.gnome.org/pub/GNOME/sources/libgtop/libgtop-%{ver}.tar.gz |
---|
14 | BuildRoot: /tmp/libgtop-root |
---|
15 | Packager: Martin Baulig <martin@home-of-linux.org> |
---|
16 | URL: http://www.home-of-linux.org/gnome/libgtop/ |
---|
17 | Prereq: /sbin/install-info |
---|
18 | Docdir: %{prefix}/doc |
---|
19 | |
---|
20 | %description |
---|
21 | |
---|
22 | A library that fetches information about the running system such as |
---|
23 | cpu and memory usage, active processes etc. |
---|
24 | |
---|
25 | On Linux systems, these information are taken directly from the /proc |
---|
26 | filesystem while on other systems a server is used to read those |
---|
27 | information from /dev/kmem or whatever. |
---|
28 | |
---|
29 | %package devel |
---|
30 | Summary: Libraries, includes, etc to develop LibGTop applications |
---|
31 | Group: X11/libraries |
---|
32 | Requires: libgtop |
---|
33 | |
---|
34 | %description devel |
---|
35 | Libraries, include files, etc you can use to develop GNOME applications. |
---|
36 | |
---|
37 | %package examples |
---|
38 | Summary: Examples for LibGTop |
---|
39 | Group: X11/libraries |
---|
40 | Requires: libgtop |
---|
41 | |
---|
42 | %description examples |
---|
43 | Examples for LibGTop. |
---|
44 | |
---|
45 | |
---|
46 | %changelog |
---|
47 | |
---|
48 | * Tue Aug 19 1998 Martin Baulig <martin@home-of-linux.org> |
---|
49 | |
---|
50 | - released LibGTop 0.25.0 |
---|
51 | |
---|
52 | * Sun Aug 16 1998 Martin Baulig <martin@home-of-linux.org> |
---|
53 | |
---|
54 | - first version of the RPM |
---|
55 | |
---|
56 | %prep |
---|
57 | %setup |
---|
58 | |
---|
59 | %build |
---|
60 | # Needed for snapshot releases. |
---|
61 | if [ ! -f configure ]; then |
---|
62 | CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix --without-linux-table --with-libgtop-inodedb --with-libgtop-examples --with-libgtop-guile --with-libgtop-smp |
---|
63 | else |
---|
64 | %ifarch alpha |
---|
65 | CFLAGS="$RPM_OPT_FLAGS" ./configure --host=alpha-redhat-linux --prefix=%prefix --without-linux-table --with-libgtop-inodedb --with-libgtop-examples --with-libgtop-guile --with-libgtop-smp |
---|
66 | %else |
---|
67 | CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix --without-linux-table --with-libgtop-inodedb --with-libgtop-examples --with-libgtop-guile --with-libgtop-smp |
---|
68 | %endif |
---|
69 | fi |
---|
70 | |
---|
71 | if [ "$SMP" != "" ]; then |
---|
72 | (make "MAKE=make -k -j $SMP"; exit 0) |
---|
73 | make |
---|
74 | else |
---|
75 | make |
---|
76 | fi |
---|
77 | |
---|
78 | %install |
---|
79 | rm -rf $RPM_BUILD_ROOT |
---|
80 | |
---|
81 | make prefix=$RPM_BUILD_ROOT%{prefix} install |
---|
82 | |
---|
83 | # |
---|
84 | # msf - remove these as they are really supposed to come from gnome-libs |
---|
85 | # |
---|
86 | # martin - don't remove since they are no longer installed if build |
---|
87 | # with GNOME |
---|
88 | # |
---|
89 | # rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.a |
---|
90 | # rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.la |
---|
91 | # rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.so.0 |
---|
92 | # rm -f $RPM_BUILD_ROOT/%{prefix}/lib/libgnomesupport.so.0.0.0 |
---|
93 | |
---|
94 | rm -fr $RPM_BUILD_ROOT/%{prefix}/include/libgtop |
---|
95 | |
---|
96 | %clean |
---|
97 | rm -rf $RPM_BUILD_ROOT |
---|
98 | |
---|
99 | %post -p /sbin/ldconfig |
---|
100 | |
---|
101 | %postun -p /sbin/ldconfig |
---|
102 | |
---|
103 | %files |
---|
104 | %defattr(-, root, root) |
---|
105 | |
---|
106 | %doc RELNOTES-0.25 RELNOTES-1.0 AUTHORS ChangeLog NEWS README |
---|
107 | %doc TODO NEWS.old copyright.txt |
---|
108 | %doc src/inodedb/README.inodedb |
---|
109 | |
---|
110 | %{prefix}/lib/lib*.so.* |
---|
111 | %{prefix}/share/* |
---|
112 | %{prefix}/bin/* |
---|
113 | |
---|
114 | %files devel |
---|
115 | %defattr(-, root, root) |
---|
116 | |
---|
117 | %{prefix}/lib/lib*.so |
---|
118 | %{prefix}/lib/*a |
---|
119 | %{prefix}/lib/*.sh |
---|
120 | %{prefix}/lib/*.def |
---|
121 | %{prefix}/include/* |
---|
122 | |
---|
123 | %files examples |
---|
124 | %defattr(-,root,root) |
---|
125 | |
---|
126 | %{prefix}/libexec/libgtop |
---|