source: trunk/third/libole2/libole2.spec @ 17442

Revision 17442, 1.9 KB checked in by ghudson, 23 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r17441, which included commits to RCS files with non-trunk default branches.
RevLine 
[17441]1%define name libole2
2%define version 0.2.4
3%define release 1
4%define prefix /usr
5
6Summary: Structured Storage OLE2 library
7
8Name: %{name}
9Version: %{version}
10Release: %{release}
11Group: System Environment/Libraries
12Copyright: GPL
13
14Source: ftp://ftp.gnome.org/pub/GNOME/unstable/sources/libole2/libole2-%{version}.tar.gz
15Buildroot: /var/tmp/%{name}-%{version}-%{release}-root
16
17%description
18A library containing functionality to manipulate OLE2 Structured Storage files. It is used by Gnumeric from Gnome, AbiWord from AbiSuite and by other programs.
19
20%package devel
21Summary: Libraries, includes, etc to develop libole2 applications
22Group: Development/Libraries
23Requires: libole2
24
25%description devel
26Libraries, include files, etc you can use to develop libole2 applications.
27
28%prep
29
30%setup
31
32%build
33%ifarch alpha
34  MYARCH_FLAGS="--host=alpha-redhat-linux"
35%endif
36
37if [ ! -f configure ]; then
38CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{prefix}
39else
40CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix}
41fi
42
43if [ "$SMP" != "" ]; then
44  (make "MAKE=make -k -j $SMP"; exit 0)
45  make
46else
47  make
48fi
49
50%install
51if [ -d $RPM_BUILD_ROOT ]; then rm -r $RPM_BUILD_ROOT; fi
52mkdir -p $RPM_BUILD_ROOT%{prefix}
53make prefix=$RPM_BUILD_ROOT%{prefix} install
54
55%files
56%defattr(-,root,root)
57%doc AUTHORS COPYING README
58%{prefix}/lib/lib*.so.*
59%{prefix}/share/aclocal/*.m4
60%{prefix}/share/libole2/html/libole2/*.html
61%{prefix}/share/libole2/html/*.html
62%{prefix}/share/libole2/html/*.txt
63
64%files devel
65%defattr(-,root,root)
66%attr(755,root,root) %{prefix}/bin/libole2-config
67%{prefix}/lib/lib*.so
68%{prefix}/lib/*a
69%{prefix}/lib/*.sh
70%{prefix}/include/libole2/*
71
72%clean
73rm -r $RPM_BUILD_ROOT
74
75%changelog
76* Sun Oct 22 2000 John Gotts <jgotts@linuxsavvy.com>
77- Minor updates.
78* Wed Jun 28 2000 Arturo Tena <arturo@directmail.org>
79- Updated summary and description.
80* Sun May 23 2000 John Gotts <jgotts@linuxsavvy.com>
81- New SPEC file.
Note: See TracBrowser for help on using the repository browser.