1 | |
---|
2 | Name: librep |
---|
3 | Version: 0.15.2 |
---|
4 | Release: 1 |
---|
5 | Summary: An embeddable LISP environment |
---|
6 | Copyright: GPL |
---|
7 | Group: Development/Languages |
---|
8 | Source: http://download.sourceforge.net/librep/librep-%{version}.tar.gz |
---|
9 | URL: http://librep.sourceforge.net/ |
---|
10 | Packager: John Harper <john@dcs.warwick.ac.uk> |
---|
11 | Buildroot: /var/tmp/%{name}-root |
---|
12 | BuildPrereq: gmp-devel gdbm-devel readline-devel texinfo |
---|
13 | PreReq: /sbin/install-info |
---|
14 | Requires: gdbm >= 1.8 |
---|
15 | |
---|
16 | %description |
---|
17 | This is a lightweight Lisp environment for UNIX. It contains a Lisp |
---|
18 | interpreter, byte-code compiler and virtual machine. Applications may |
---|
19 | use the Lisp interpreter as an extension language, or it may be used |
---|
20 | for standalone scripts. |
---|
21 | |
---|
22 | Originally inspired by Emacs Lisp, the language dialect combines many |
---|
23 | of the elisp features while trying to remove some of the main |
---|
24 | deficiencies, with features from Common Lisp and Scheme. |
---|
25 | |
---|
26 | %package devel |
---|
27 | Summary: librep include files and link libraries |
---|
28 | Group: Development/Languages |
---|
29 | Requires: %{name} = 0.15.2 |
---|
30 | |
---|
31 | %description devel |
---|
32 | Link libraries and C header files for librep development. |
---|
33 | |
---|
34 | %prep |
---|
35 | %setup -q |
---|
36 | |
---|
37 | %build |
---|
38 | |
---|
39 | LC_ALL="" |
---|
40 | LINGUAS="" |
---|
41 | LANG="" |
---|
42 | export LC_ALL LINGUAS LANG |
---|
43 | |
---|
44 | %configure --with-readline --with-extra-cflags=-fstrength-reduce |
---|
45 | make host_type=%{_target_platform} |
---|
46 | |
---|
47 | %install |
---|
48 | [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT |
---|
49 | make install \ |
---|
50 | host_type=%{_target_platform} \ |
---|
51 | DESTDIR=$RPM_BUILD_ROOT \ |
---|
52 | aclocaldir=%{_datadir}/aclocal \ |
---|
53 | infodir=%{_infodir} |
---|
54 | gzip -9nf $RPM_BUILD_ROOT%{_infodir}/librep* |
---|
55 | |
---|
56 | %post |
---|
57 | /sbin/ldconfig |
---|
58 | /sbin/install-info %{_infodir}/librep.info.gz %{_infodir}/dir |
---|
59 | |
---|
60 | %preun |
---|
61 | if [ "$1" = 0 ]; then |
---|
62 | /sbin/install-info --delete %{_infodir}/librep.info.gz %{_infodir}/dir |
---|
63 | fi |
---|
64 | |
---|
65 | %postun -p /sbin/ldconfig |
---|
66 | |
---|
67 | %clean |
---|
68 | [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT |
---|
69 | |
---|
70 | %files |
---|
71 | %defattr(-,root,root) |
---|
72 | %doc NEWS README THANKS TODO BUGS |
---|
73 | %{_bindir}/rep |
---|
74 | %{_bindir}/rep-remote |
---|
75 | %{_libdir}/librep.so.* |
---|
76 | %{_datadir}/rep/%{version} |
---|
77 | %{_libexecdir}/rep/%{version}/%{_target_platform} |
---|
78 | %{_infodir}/librep* |
---|
79 | %{_datadir}/emacs/site-lisp/rep-* |
---|
80 | |
---|
81 | %files devel |
---|
82 | %defattr(-,root,root) |
---|
83 | %{_bindir}/rep-config |
---|
84 | %{_bindir}/rep-xgettext |
---|
85 | %{_bindir}/repdoc |
---|
86 | %{_libdir}/librep.so |
---|
87 | %{_includedir}/rep.h |
---|
88 | %{_includedir}/rep_*.h |
---|
89 | %{_libexecdir}/rep/%{_target_platform}/libtool |
---|
90 | %{_libexecdir}/rep/%{_target_platform}/rules.mk |
---|
91 | %{_libexecdir}/rep/%{_target_platform}/install-aliases |
---|
92 | %{_libexecdir}/rep/%{_target_platform}/rep_config.h |
---|
93 | %{_datadir}/aclocal/rep.m4 |
---|
94 | |
---|
95 | %changelog |
---|
96 | * Tue Jun 13 2000 John Harper <john@dcs.warwick.ac.uk> |
---|
97 | - use better macros |
---|
98 | |
---|
99 | * Wed Nov 10 1999 Michael K. Johnson <johnsonm@redhat.com> |
---|
100 | - post{,un} use -p |
---|
101 | |
---|
102 | * Mon Sep 13 1999 Aron Griffis <agriffis@bigfoot.com> |
---|
103 | - 0.5 spec file update: added buildroot |
---|