source: trunk/third/librep/librep.spec @ 17362

Revision 17362, 2.7 KB checked in by ghudson, 23 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r17361, which included commits to RCS files with non-trunk default branches.
Line 
1
2Name: librep
3Version: 0.15.2
4Release: 1
5Summary: An embeddable LISP environment
6Copyright: GPL
7Group: Development/Languages
8Source: http://download.sourceforge.net/librep/librep-%{version}.tar.gz
9URL: http://librep.sourceforge.net/
10Packager: John Harper <john@dcs.warwick.ac.uk>
11Buildroot: /var/tmp/%{name}-root
12BuildPrereq: gmp-devel gdbm-devel readline-devel texinfo
13PreReq: /sbin/install-info
14Requires: gdbm >= 1.8
15
16%description
17This is a lightweight Lisp environment for UNIX. It contains a Lisp
18interpreter, byte-code compiler and virtual machine. Applications may
19use the Lisp interpreter as an extension language, or it may be used
20for standalone scripts.
21
22Originally inspired by Emacs Lisp, the language dialect combines many
23of the elisp features while trying to remove some of the main
24deficiencies, with features from Common Lisp and Scheme.
25
26%package devel
27Summary: librep include files and link libraries
28Group: Development/Languages
29Requires: %{name} = 0.15.2
30
31%description devel
32Link libraries and C header files for librep development.
33
34%prep
35%setup -q
36
37%build
38
39LC_ALL=""
40LINGUAS=""
41LANG=""
42export LC_ALL LINGUAS LANG
43
44%configure --with-readline --with-extra-cflags=-fstrength-reduce
45make host_type=%{_target_platform}
46
47%install
48[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
49make install \
50    host_type=%{_target_platform} \
51    DESTDIR=$RPM_BUILD_ROOT \
52    aclocaldir=%{_datadir}/aclocal \
53    infodir=%{_infodir}
54gzip -9nf $RPM_BUILD_ROOT%{_infodir}/librep*
55
56%post
57/sbin/ldconfig
58/sbin/install-info %{_infodir}/librep.info.gz %{_infodir}/dir
59
60%preun
61if [ "$1" = 0 ]; then
62    /sbin/install-info --delete %{_infodir}/librep.info.gz %{_infodir}/dir
63fi
64
65%postun -p /sbin/ldconfig
66
67%clean
68[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(-,root,root)
72%doc NEWS README THANKS TODO BUGS
73%{_bindir}/rep
74%{_bindir}/rep-remote
75%{_libdir}/librep.so.*
76%{_datadir}/rep/%{version}
77%{_libexecdir}/rep/%{version}/%{_target_platform}
78%{_infodir}/librep*
79%{_datadir}/emacs/site-lisp/rep-*
80
81%files devel
82%defattr(-,root,root)
83%{_bindir}/rep-config
84%{_bindir}/rep-xgettext
85%{_bindir}/repdoc
86%{_libdir}/librep.so
87%{_includedir}/rep.h
88%{_includedir}/rep_*.h
89%{_libexecdir}/rep/%{_target_platform}/libtool
90%{_libexecdir}/rep/%{_target_platform}/rules.mk
91%{_libexecdir}/rep/%{_target_platform}/install-aliases
92%{_libexecdir}/rep/%{_target_platform}/rep_config.h
93%{_datadir}/aclocal/rep.m4
94
95%changelog
96* Tue Jun 13 2000 John Harper <john@dcs.warwick.ac.uk>
97- use better macros
98
99* Wed Nov 10 1999 Michael K. Johnson <johnsonm@redhat.com>
100- post{,un} use -p
101
102* Mon Sep 13 1999 Aron Griffis <agriffis@bigfoot.com>
103- 0.5 spec file update: added buildroot
Note: See TracBrowser for help on using the repository browser.