[24253] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for debathena-moira-update-server |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | # Move a conffile without triggering a dpkg question |
---|
| 21 | mv_conffile() { |
---|
[24255] | 22 | OLDCONFFILE="$1" |
---|
| 23 | NEWCONFFILE="$2" |
---|
[24253] | 24 | |
---|
| 25 | [ -e "$OLDCONFFILE" ] || return 0 |
---|
| 26 | |
---|
| 27 | echo "Preserving user changes to $NEWCONFFILE ..." |
---|
| 28 | mv -f "$NEWCONFFILE" "$NEWCONFFILE".dpkg-new |
---|
| 29 | mv -f "$OLDCONFFILE" "$NEWCONFFILE" |
---|
| 30 | } |
---|
| 31 | |
---|
| 32 | case "$1" in |
---|
| 33 | configure) |
---|
| 34 | if dpkg --compare-versions "$2" lt 4.0.0+svn20100104-0debathena1~; then |
---|
| 35 | mv_conffile /etc/athena/moira.conf /etc/moira.conf |
---|
| 36 | |
---|
| 37 | # If that empties out /etc/athena, then delete it |
---|
| 38 | rmdir --ignore-fail-on-non-empty /etc/athena |
---|
| 39 | fi |
---|
[25073] | 40 | if dpkg --compare-versions "$2" lt 4.0.0+svn20100405-0debathena2~; then |
---|
| 41 | # If they're upgrading from a version that pre-dates |
---|
| 42 | # the defaults file, then they probably had it installed for |
---|
| 43 | # a reason, so we should turn it on (if it's not a cluster machine) |
---|
| 44 | if ! dpkg-query --showformat '${Status}\n' -W "debathena-cluster" 2>/dev/null | grep -q ' installed$'; then |
---|
| 45 | sed -i -e 's/^ENABLED=.*$/ENABLED=true/' /etc/default/debathena-moira-update-server |
---|
| 46 | fi |
---|
| 47 | fi |
---|
[24253] | 48 | ;; |
---|
| 49 | |
---|
| 50 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 51 | ;; |
---|
| 52 | |
---|
| 53 | *) |
---|
| 54 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 55 | exit 1 |
---|
| 56 | ;; |
---|
| 57 | esac |
---|
| 58 | |
---|
| 59 | # dh_installdeb will replace this with shell code automatically |
---|
| 60 | # generated by other debhelper scripts. |
---|
| 61 | |
---|
| 62 | #DEBHELPER# |
---|
| 63 | |
---|
| 64 | exit 0 |
---|
| 65 | |
---|
| 66 | |
---|