source: trunk/third/moira/debian/debathena-moira-update-server.postinst @ 24255

Revision 24255, 1.5 KB checked in by broder, 15 years ago (diff)
Assorted cleanup in moira: - Squelch some bashisms in the update-server {pre,post}insts - Remove files no longer in the SVN repository - Fix the clean target to remove a modified libtool file.
  • Property svn:executable set to *
Line 
1#!/bin/sh
2# postinst script for debathena-moira-update-server
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20# Move a conffile without triggering a dpkg question
21mv_conffile() {
22    OLDCONFFILE="$1"
23    NEWCONFFILE="$2"
24
25    [ -e "$OLDCONFFILE" ] || return 0
26
27    echo "Preserving user changes to $NEWCONFFILE ..."
28    mv -f "$NEWCONFFILE" "$NEWCONFFILE".dpkg-new
29    mv -f "$OLDCONFFILE" "$NEWCONFFILE"
30}
31
32case "$1" in
33    configure)
34        if dpkg --compare-versions "$2" lt 4.0.0+svn20100104-0debathena1~; then
35            mv_conffile /etc/athena/moira.conf /etc/moira.conf
36
37            # If that empties out /etc/athena, then delete it
38            rmdir --ignore-fail-on-non-empty /etc/athena
39        fi
40    ;;
41
42    abort-upgrade|abort-remove|abort-deconfigure)
43    ;;
44
45    *)
46        echo "postinst called with unknown argument \`$1'" >&2
47        exit 1
48    ;;
49esac
50
51# dh_installdeb will replace this with shell code automatically
52# generated by other debhelper scripts.
53
54#DEBHELPER#
55
56exit 0
57
58
Note: See TracBrowser for help on using the repository browser.