source: trunk/third/oaf/oaf.spec @ 18115

Revision 18115, 3.1 KB checked in by ghudson, 22 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18114, which included commits to RCS files with non-trunk default branches.
Line 
1Name:           oaf
2Summary:        Object activation framework for GNOME
3Version:        0.6.10
4Release:        1
5License:        LGPL and GPL
6Group:          System Environment/Libraries
7Source:         ftp://ftp.gnome.org/pub/GNOME/unstable/sources/%{name}/%{name}-%{version}.tar.gz
8URL:            http://www.gnome.org/
9BuildRoot:      %{_tmpdir}/%{name}-%{version}-root
10
11%description
12OAF is an object activation framework for GNOME. It uses ORBit.
13
14%package devel
15Summary:        Libraries and include files for OAF
16Group:          Development/Libraries
17Requires:       %{name} = %{version}
18
19%description devel
20Development headers and libraries for OAF.
21
22%prep
23%setup -q
24
25%build
26%ifarch alpha
27        MYARCH_FLAGS="--host=alpha-redhat-linux"
28%endif
29
30LC_ALL=""
31LINGUAS=""
32LANG=""
33export LC_ALL LINGUAS LANG
34
35CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS \
36        --enable-more-warnings --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} --bindir=%{_bindir} \
38        --libdir=%{_libdir} --datadir=%{_datadir} \
39        --includedir=%{_includedir}
40
41make -k
42
43%install
44[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
45
46make -k prefix=$RPM_BUILD_ROOT/%{_prefix} \
47    sysconfdir=$RPM_BUILD_ROOT/%{_sysconfdir} \
48    bindir=$RPM_BUILD_ROOT/%{_bindir} \
49    libdir=$RPM_BUILD_ROOT/%{_libdir} \
50    datadir=$RPM_BUILD_ROOT/%{_datadir} \
51    includedir=$RPM_BUILD_ROOT/%{_includedir} install
52
53%find_lang %name
54
55%clean
56[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
57
58%post -p /sbin/ldconfig
59 
60%postun -p /sbin/ldconfig
61
62%files -n %{name}.lang
63%defattr(0555, root, root)
64
65%doc AUTHORS COPYING ChangeLog NEWS README
66%config %{_sysconfdir}/oaf
67%{_bindir}/*
68%{_libdir}/*.so.*
69
70%defattr (0444, root, root)
71%{_datadir}/idl/*.idl
72%{_datadir}/oaf/*.oafinfo
73
74%files devel
75
76%defattr(0555, bin, bin)
77%dir %{prefix}/include/liboaf
78%{_libdir}/*.la
79%{_libdir}/*.so
80%{_libdir}/*.sh
81
82%defattr(0444, bin, bin)
83%{_includedir}/liboaf
84%{_datadir}/aclocal/*.m4
85
86
87%changelog
88* Sun Aug 26 2001 Gregory Leblanc <gleblanc@linuxweasel.com>
89- remove some unnecessary %defines
90- used the %find_lang macro for i18n.  Makes many translators happy
91- replaced %{prefix}/lib with %{_libdir} in the files section
92- simplified files section
93- replaced %{prefix}/bin with %{_bindir} in the files section
94- added bindir, libdir, datadir, includedir to the configure and make install stages
95- made %post script not bother to check if the correct path is already in /etc/ld.so.conf
96- removed explicit stripping of binaries.  RPM does this automagically
97- made configure and make install stages use RPMs built-in location macros
98- made the setup step quiet
99- added a description for the devel package
100- made -devel not obsolete itself (not sure why it needed to in the first place)
101- removed explicit definition of DocDir
102- fixed BuildRoot
103- fixed Source URL
104- move ChangeLog to the end of the file (so that it's easier to read)
105- moved some files into the -devel rpm
106- changed default ownerships to be root, although we're still not quite decided on this one
107
108* Tue Aug 29 2000 Maciej Stachowiak <mjs@eazel.com>
109- corrected Copyright field and renamed it to License
110
111* Sun May 21 2000 Ross Golder <rossigee@bigfoot.com>
112- created spec file (based on bonobo.spec.in)
Note: See TracBrowser for help on using the repository browser.