1 | Summary: ScrollKeeper is a cataloging system for documentation on open systems |
---|
2 | Name: scrollkeeper |
---|
3 | Version: 0.2 |
---|
4 | Release: 1 |
---|
5 | Source0: http://download.sourceforge.net/scrollkeeper/%{name}-%{version}.tar.gz |
---|
6 | Copyright: LGPL |
---|
7 | Group: System Environment/Base |
---|
8 | BuildRoot: %{_tmppath}/%{name}-buildroot |
---|
9 | URL: http://scrollkeeper.sourceforge.net/ |
---|
10 | Requires: libxml |
---|
11 | |
---|
12 | |
---|
13 | %description |
---|
14 | ScrollKeeper is a cataloging system for documentation. It manages |
---|
15 | documentation metadata (as specified by the Open Source Metadata |
---|
16 | Framework (OMF)) and provides a simple API to allow help browsers to |
---|
17 | find, sort, and search the document catalog. It will also be able to |
---|
18 | communicate with catalog servers on the Net to search for documents |
---|
19 | which are not on the local system. |
---|
20 | |
---|
21 | %prep |
---|
22 | %setup |
---|
23 | |
---|
24 | %build |
---|
25 | %configure |
---|
26 | if [ "$SMP" != "" ]; then |
---|
27 | make -j$SMP "MAKE=make -j$SMP" |
---|
28 | else |
---|
29 | make |
---|
30 | fi |
---|
31 | |
---|
32 | |
---|
33 | %install |
---|
34 | rm -rf $RPM_BUILD_ROOT |
---|
35 | %makeinstall |
---|
36 | # mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/scrollkeeper/Templates |
---|
37 | pushd ${RPM_BUILD_ROOT}%{_datadir}/scrollkeeper/Templates |
---|
38 | rm -rf en && ln -sf C en |
---|
39 | rm -rf no* && ln -sf nb no && ln -sf nn no_NY |
---|
40 | for lang in bg_BG bg_BG.cp1251 de_AT en_AU en_GB en_SE en_UK en_US es_DO \ |
---|
41 | es_ES es_GT es_HN es_MX es_PA es_PE es_SV ja_JP.eucJP pt_PT \ |
---|
42 | sr_YU sv_SE zh_CN zh_CN.GB2312 zh_TW zh_TW.Big5 ; do |
---|
43 | l=${lang%_*} |
---|
44 | rm -rf $lang |
---|
45 | ln -sf $l $lang |
---|
46 | done |
---|
47 | popd |
---|
48 | |
---|
49 | %clean |
---|
50 | rm -rf $RPM_BUILD_ROOT |
---|
51 | |
---|
52 | %pre |
---|
53 | if test -L %{_datadir}/scrollkeeper/Templates/pt_BR; then |
---|
54 | rm %{_datadir}/scrollkeeper/Templates/pt_BR |
---|
55 | fi |
---|
56 | |
---|
57 | %files |
---|
58 | %defattr(-,root,root) |
---|
59 | %doc COPYING COPYING-DOCS AUTHORS README ChangeLog NEWS INSTALL |
---|
60 | %{_datadir}/omf/scrollkeeper |
---|
61 | %{_bindir}/* |
---|
62 | %{_libdir}/* |
---|
63 | %{_mandir}/man8/* |
---|
64 | %{_datadir}/scrollkeeper |
---|
65 | %{_datadir}/locale/*/* |
---|
66 | |
---|
67 | |
---|
68 | %post |
---|
69 | if [ $1 = 1 ]; then |
---|
70 | # There was previously no SK installed. |
---|
71 | # ie. make a new %{_localstatedir}/lib/scrollkeeper. |
---|
72 | # Blow away any old database that might be there, in case |
---|
73 | # the user installed from tarball in the past. |
---|
74 | rm -rf %{_localstatedir}/lib/scrollkeeper |
---|
75 | mkdir %{_localstatedir}/lib/scrollkeeper |
---|
76 | scrollkeeper-update -p %{_localstatedir}/lib/scrollkeeper |
---|
77 | fi |
---|
78 | if [ $1 = 2 ]; then |
---|
79 | # There was previously a SK installed. |
---|
80 | # ie. don't make a new %{_localstatedir}/lib/scrollkeeper. |
---|
81 | # However, version 0.0.4 of SK did not properly create this |
---|
82 | # directory if a previous SK was installed, so just to be sure... |
---|
83 | rm -rf %{_localstatedir}/lib/scrollkeeper |
---|
84 | mkdir %{_localstatedir}/lib/scrollkeeper |
---|
85 | scrollkeeper-update -p %{_localstatedir}/lib/scrollkeeper |
---|
86 | fi |
---|
87 | |
---|
88 | %postun |
---|
89 | if [ $1 = 0 ]; then |
---|
90 | # SK is being removed, not upgraded. |
---|
91 | # ie. erase {localstatedir}/lib/scrollkeeper. |
---|
92 | rm -rf %{_localstatedir}/lib/scrollkeeper |
---|
93 | fi |
---|
94 | #if [ $1 = 1 ]; then |
---|
95 | # # SK is being upgraded. Do not erase {localstatedir}/lib/scrollkeeper. |
---|
96 | #fi |
---|
97 | # |
---|
98 | # Make sure no junk is left in the old template directory, |
---|
99 | # since upgrade from 0.1.1 to 0.1.2 was broken and can leave |
---|
100 | # files there. |
---|
101 | rm -rf %{_datadir}/scrollkeeper/templates |
---|
102 | |
---|
103 | %changelog |
---|
104 | * Mon Mar 5 2001 Dan Mueth <dan@eazel.com> |
---|
105 | - Added %postun to remove $datadir/scrollkeeper/templates |
---|
106 | to compensate for breakage in upgrade from 0.1.1 to 0.1.2 |
---|
107 | |
---|
108 | * Sun Mar 4 2001 Dan Mueth <dan@eazel.com> |
---|
109 | - Added cleaner symbolic link section suggested by Karl |
---|
110 | Eichwalder <keichwa@users.sourceforge.net> |
---|
111 | - Have it blow away the database dir on first install, just |
---|
112 | in case an old tarball version had been installed |
---|
113 | - Fixing the Source0 line at the top |
---|
114 | |
---|
115 | * Tue Feb 15 2001 Dan Mueth <dan@eazel.com> |
---|
116 | - added line to include the translations .mo file |
---|
117 | |
---|
118 | * Tue Feb 06 2001 Dan Mueth <dan@eazel.com> |
---|
119 | - fixed up pre and post installation scripts |
---|
120 | |
---|
121 | * Tue Feb 06 2001 Laszlo Kovacs <laszlo.kovacs@sun.com> |
---|
122 | - added all the locale directories and links for the template |
---|
123 | content list files |
---|
124 | |
---|
125 | * Wed Jan 17 2001 Gregory Leblanc <gleblanc@cu-portland.edu> |
---|
126 | - converted to scrollkeeper.spec.in |
---|
127 | |
---|
128 | * Sat Dec 16 2000 Laszlo Kovacs <laszlo.kovacs@sun.com> |
---|
129 | - help files added |
---|
130 | |
---|
131 | * Fri Dec 8 2000 Laszlo Kovacs <laszlo.kovacs@sun.com> |
---|
132 | - various small fixes added |
---|
133 | |
---|
134 | * Thu Dec 7 2000 Laszlo Kovacs <laszlo.kovacs@sun.com> |
---|
135 | - fixing localstatedir problem |
---|
136 | - adding postinstall and postuninstall scripts |
---|
137 | |
---|
138 | * Tue Dec 5 2000 Gregory Leblanc <gleblanc@cu-portland.edu> |
---|
139 | - adding COPYING, AUTHORS, etc |
---|
140 | - fixed localstatedir for the OMF files |
---|
141 | |
---|
142 | * Fri Nov 10 2000 Gregory Leblanc <gleblanc@cu-portland.edu> |
---|
143 | - Initial spec file created. |
---|
144 | |
---|
145 | |
---|