source: trunk/third/scrollkeeper/scrollkeeper.spec @ 20861

Revision 20861, 5.4 KB checked in by ghudson, 20 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r20860, which included commits to RCS files with non-trunk default branches.
Line 
1%define xmlcatalog      %{_sysconfdir}/xml/catalog     
2
3Summary:    ScrollKeeper is a cataloging system for documentation on open systems.
4Name:       scrollkeeper
5Version:    0.3.14
6Release:    1
7Source0:    http://download.sourceforge.net/scrollkeeper/%{name}-%{version}.tar.gz
8License:    LGPL
9Group:      System Environment/Base
10BuildRoot:  %{_tmppath}/%{name}-buildroot
11URL:        http://scrollkeeper.sourceforge.net/
12Requires:   libxml2 >= 2.4.19
13Requires:   libxslt
14BuildRequires:   libxml2-devel
15BuildRequires:   libxslt-devel
16
17
18%description
19ScrollKeeper is a cataloging system for documentation. It manages
20documentation metadata, as specified by the Open Source Metadata
21Framework (OMF), as well as metadata which it extracts directly
22from DocBook documents.  It provides a simple API to allow help
23browsers to find, sort, and search the document catalog. Some
24day it may also be able to communicate with catalog servers on
25the Net to search for documents which are not on the local system.
26
27%prep
28%setup
29
30%build
31%configure
32make %{?_smp_mflags}
33
34%install
35if [ ! $RPM_BUILD_ROOT = "/" ]; then rm -rf $RPM_BUILD_ROOT; fi
36%makeinstall
37if [ ! $RPM_BUILD_ROOT = "/" ]; then rm -rf $RPM_BUILD_ROOT/var; fi
38                # We must remove .../var b/c rpm >=4.1 doesn't allow
39                # files which are not packaged in the buildroot.
40
41%find_lang %{name}
42
43%clean
44if [ ! $RPM_BUILD_ROOT = "/" ]; then rm -rf $RPM_BUILD_ROOT; fi
45
46%pre
47rm -rf %{_datadir}/scrollkeeper/Templates || true
48
49%files -f %{name}.lang
50%defattr(-,root,root)
51%doc COPYING COPYING.DOC AUTHORS README ChangeLog NEWS INSTALL TODO
52%doc scrollkeeper-spec.txt
53%config %{_sysconfdir}/*
54%{_datadir}/omf/scrollkeeper
55%{_bindir}/*
56%{_libdir}/*
57%{_mandir}/*/*
58%{_datadir}/xml/scrollkeeper
59%{_datadir}/scrollkeeper
60
61
62%post
63if [ $1 = 2 ]; then
64  # Upgrading
65  echo "`date +"%b %d %X"` Upgrading to ScrollKeeper `scrollkeeper-config --version`..." >> %{_localstatedir}/log/scrollkeeper.log
66fi
67if [ $1 = 1 ]; then
68  # Installing
69  echo "`date +"%b %d %X"` Installing ScrollKeeper `scrollkeeper-config --version`..." >> %{_localstatedir}/log/scrollkeeper.log
70fi
71/usr/bin/xmlcatalog --noout --add "public" \
72        "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" \
73        "%{_datadir}/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd" %xmlcatalog
74scrollkeeper-rebuilddb -q -p %{_localstatedir}/lib/scrollkeeper || true
75/sbin/ldconfig
76
77%postun
78if [ $1 = 0 ]; then
79  # SK is being removed, not upgraded.
80  # Remove all generated files
81  rm -rf %{_localstatedir}/lib/scrollkeeper
82  rm -rf %{_localstatedir}/log/scrollkeeper.log
83  rm -rf %{_localstatedir}/log/scrollkeeper.log.1
84  /usr/bin/xmlcatalog --noout --del \
85        "%{_datadir}/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd" %xmlcatalog
86fi
87/sbin/ldconfig
88
89%changelog
90* Sat Dec 6 2003 Malcolm Tredinnick <malcolm@commsecure.com.au>
91- Remove some needless Requires.
92- Add some more documentation.
93
94* Wed Jan 22 2003 Dan Mueth <muet@alumni.uchicago.edu>
95- Fix duplication of *.mo files and added removal of .../var files at end
96-  of build to satisfy rpm >= 4.1.
97
98* Sun Apr 7 2002 Dan Mueth <muet@alumni.uchicago.edu>
99- Adding DTD to %files and xmlcatalog registration scripts to %post and %postun
100
101* Thu Apr 4 2002 Dan Mueth <muet@alumni.uchicago.edu>
102- Integrating some of Red Hat's modifications
103
104* Sun Feb 17 2002 Dan Mueth <muet@alumni.uchicago.edu>
105- Making sysconfdir files as %config
106
107* Fri Feb 8 2002 Dan Mueth <d-mueth@uchicago.edu>
108- Small updates to keep from blowing away / by accident, thanks to Paul
109-       Heinlein <heinlein@measurecast.com>
110
111* Tue Jan 15 2002 Dan Mueth <d-mueth@uchicago.edu>
112- Having variable files only removed by %postun on an rpm removal, not on an upgrade.
113- Changing the three manual lines for database rebuildding with scrollkeeper-rebuilddb
114- Adding logging lines for upgrading/installing
115- Note: From SK 0.2 to 0.3.1, we had a badly written %postun which blows away
116-       the rebuilt database after an upgrade :(
117
118* Sun Jan 13 2002 Dan Mueth <d-mueth@uchicago.edu>
119- Added BuildRequires for libxml2-devel
120
121* Sat Jan 12 2002 Dan Mueth <d-mueth@uchicago.edu>
122- Added %postun to remove log files.
123
124* Mon Mar 5 2001 Dan Mueth <dan@eazel.com>
125- Added %postun to remove $datadir/scrollkeeper/templates
126  to compensate for breakage in upgrade from 0.1.1 to 0.1.2
127
128* Sun Mar 4 2001 Dan Mueth <dan@eazel.com>
129- Added cleaner symbolic link section suggested by Karl
130  Eichwalder <keichwa@users.sourceforge.net>
131- Have it blow away the database dir on first install, just
132  in case an old tarball version had been installed
133- Fixing the Source0 line at the top
134
135* Tue Feb 15 2001 Dan Mueth <dan@eazel.com>
136- added line to include the translations .mo file
137
138* Tue Feb 06 2001 Dan Mueth <dan@eazel.com>
139- fixed up pre and post installation scripts
140
141* Tue Feb 06 2001 Laszlo Kovacs <laszlo.kovacs@sun.com>
142- added all the locale directories and links for the template
143  content list files
144
145* Wed Jan 17 2001 Gregory Leblanc <gleblanc@cu-portland.edu>
146- converted to scrollkeeper.spec.in
147
148* Sat Dec 16 2000 Laszlo Kovacs <laszlo.kovacs@sun.com>
149- help files added
150
151* Fri Dec 8 2000 Laszlo Kovacs <laszlo.kovacs@sun.com>
152- various small fixes added
153
154* Thu Dec 7 2000 Laszlo Kovacs <laszlo.kovacs@sun.com>
155- fixing localstatedir problem
156- adding postinstall and postuninstall scripts
157
158* Tue Dec 5 2000 Gregory Leblanc <gleblanc@cu-portland.edu>
159- adding COPYING, AUTHORS, etc
160- fixed localstatedir for the OMF files
161
162* Fri Nov 10 2000 Gregory Leblanc <gleblanc@cu-portland.edu>
163- Initial spec file created.
164
165
Note: See TracBrowser for help on using the repository browser.