source: trunk/third/soup/soup.spec @ 18149

Revision 18149, 2.4 KB checked in by ghudson, 22 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18148, which included commits to RCS files with non-trunk default branches.
RevLine 
[18148]1# Note that this is NOT a relocatable package
2%define ver      0.7.10
3%define rel      1
4%define prefix   /usr
5
6Summary: Soup, a SOAP implementation
7Name:      soup
8Version:   %ver
9Release:   %rel
10Copyright: LGPL
11Group:     Libraries/Network
12Source0:   soup-%{PACKAGE_VERSION}.tar.gz
13URL:       http://www.ximian.com/applications/soup
14BuildRoot: /var/tmp/soup-%{PACKAGE_VERSION}-root
15Docdir:    %{prefix}/doc
16Packager:  Alex Graveley <alex@ximian.com>
17Requires:  glib >= 1.2
18Requires:  libxml >= 1.8
19
20%description
21Soup is a SOAP (Simple Object Access Protocol) implementation in C. It
22provides an queued asynchronous callback-based mechanism for sending
23SOAP requests. A WSDL (Web Service Definition Language) to C compiler
24which generates stubs for easily calling remote SOAP methods, and a
25CORBA IDL to WSDL compiler are also included.
26
27Features:
28  * Completely Asynchronous
29  * Connection cache
30  * HTTP chunked transfer support
31  * authenticated HTTP, SOCKS4, and SOCKS5 proxy support
32  * SSL Support using either OpenSSL or NSS
33
34Soup requires Glib 1.2 and LibXML 1.8.  You can find Glib at
35http://www.gtk.org, and LibXML at
36http://rufus.w3.org/veillard/XML/xml.html.
37
38Comments, questions, and bug reports should be sent to
39alex@ximian.com.
40
41The Soup homepage is at http://www.ximian.com/applications/soup.
42
43%package devel
44Summary: Header files for the Soup library
45Group: Development/Libraries
46
47%description devel
48Soup is a SOAP (Simple Object Access Protocol) implementation in C. It
49provides an queued asynchronous callback-based mechanism for sending
50SOAP requests.
51This package allows you to develop applications that use the Soup
52library.
53
54
55%prep
56%setup
57
58%build
59%ifarch alpha
60   CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" ./configure --host=alpha-redhat-linux\
61        --prefix=%{prefix} \
62        --enable-debug=yes \
63        --with-gnu-ld
64%else
65   CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" ./configure \
66        --prefix=%{prefix} \
67        --enable-debug=yes \
68        --with-gnu-ld
69%endif
70make
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75make prefix=$RPM_BUILD_ROOT%{prefix} install
76
77%post
78/sbin/ldconfig
79
80%postun
81/sbin/ldconfig
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(-, root, root)
88%doc README COPYING ChangeLog NEWS TODO AUTHORS INSTALL HACKING doc/html
89%{prefix}/lib/lib*.so*
90
91%files devel
92%defattr(-, root, root)
93%{prefix}/bin/soup-config
94%{prefix}/include/soup
95%{prefix}/lib/*a
96%{prefix}/lib/soupConf.sh
97%{prefix}/share/aclocal/soup.m4
98
99%changelog
100* Tue Jan 23 2001 Alex Graveley <alex@ximian.com>
101- Inital RPM config.
Note: See TracBrowser for help on using the repository browser.