source: trunk/third/tiff/dist/tiff.spec @ 18174

Revision 18174, 2.2 KB checked in by ghudson, 22 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18173, which included commits to RCS files with non-trunk default branches.
Line 
1#       $Header: /afs/dev.mit.edu/source/repository/third/tiff/dist/tiff.spec,v 1.1.1.1 2002-12-26 02:37:36 ghudson Exp $
2#
3# TIFF Software
4#
5# Copyright (c) 1994-1997 Sam Leffler
6# Copyright (c) 1994-1997 Silicon Graphics, Inc.
7#
8# Permission to use, copy, modify, distribute, and sell this software and
9# its documentation for any purpose is hereby granted without fee, provided
10# that (i) the above copyright notices and this permission notice appear in
11# all copies of the software and related documentation, and (ii) the names of
12# Sam Leffler and Silicon Graphics may not be used in any advertising or
13# publicity relating to the software without the specific, prior written
14# permission of Sam Leffler and Silicon Graphics.
15#
16# THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,
17# EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
18# WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
19#
20# IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
21# ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
22# OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
23# WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF
24# LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
25# OF THIS SOFTWARE.
26#
27define CUR_MAJ_VERS     1006            # Major Version number
28define CUR_MIN_VERS     001             # Minor Version number
29define CUR_VERS         ${CUR_MAJ_VERS}${CUR_MIN_VERS}${ALPHA}
30define TIFF_NAME        "TIFF"
31
32include tiff.version
33include tiff.alpha
34
35product tiff
36    id  "${TIFF_NAME} Tools, Version ${TIFF_VNUM}"
37    inplace
38
39    image sw
40        id      "${TIFF_NAME} Software"
41        version "${CUR_VERS}"
42        subsys tools default
43            id  "${TIFF_NAME} Tools & Library DSO"
44            exp "tiff.sw.tools"
45        endsubsys
46        subsys dev
47            id  "${TIFF_NAME} Developement Software"
48            exp "tiff.sw.dev"
49        endsubsys
50    endimage
51
52    image man
53        id      "${TIFF_NAME} Documentation"
54        version "${CUR_VERS}"
55        subsys tools default
56            id  "${TIFF_NAME} Tools Manual Pages"
57            exp "tiff.man.tools"
58        endsubsys
59        subsys dev
60            id  "${TIFF_NAME} Library Manual Pages"
61            exp "tiff.man.dev"
62        endsubsys
63        subsys html
64            id  "${TIFF_NAME} HTML Materials"
65            exp "tiff.man.html"
66        endsubsys
67    endimage
68endproduct
Note: See TracBrowser for help on using the repository browser.