source: trunk/third/vte/vte.spec @ 20883

Revision 20883, 20.8 KB checked in by ghudson, 20 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r20882, which included commits to RCS files with non-trunk default branches.
Line 
1Name: vte
2Version: 0.11.11
3Release: 1
4Summary: An experimental terminal emulator.
5License: LGPL
6Group: User Interface/X
7BuildRoot: %{_tmppath}/%{name}-root
8Source: %{name}-%{version}.tar.gz
9BuildPrereq: gtk-doc, gtk2-devel, pygtk2-devel, python-devel
10Requires: bitmap-fonts
11
12%description
13VTE is an experimental terminal emulator widget for use with GTK+ 2.0.
14
15%package devel
16Summary: Files needed for developing applications which use vte.
17Group: Development/Libraries
18Requires: %{name} = %{version}-%{release}, gtk2-devel
19
20%description devel
21VTE is an experimental terminal emulator widget for use with GTK+ 2.0.  This
22package contains the files needed for building applications using VTE.
23
24%prep
25%setup -q
26
27%build
28if [ -x %{_bindir}/python2.2 ]; then
29        PYTHON=%{_bindir}/python2.2; export PYTHON
30fi
31%configure --enable-shared --enable-static --libexecdir=%{_libdir}/%{name} --without-glX --with-default-emulation=xterm
32make
33
34%clean
35rm -fr $RPM_BUILD_ROOT
36
37%install
38rm -fr $RPM_BUILD_ROOT
39make install DESTDIR=$RPM_BUILD_ROOT
40
41# Remove the sample app.
42rm $RPM_BUILD_ROOT/%{_bindir}/%{name}
43
44# Remove the .la file.
45rm $RPM_BUILD_ROOT/%{_libdir}/lib%{name}.la
46
47# Work around AM_PATH_PYTHON from automake 1.6.3 not being multilib-aware.
48if test %{_libdir} != %{_prefix}/lib ; then
49        badpyexecdir=`ls -d $RPM_BUILD_ROOT/%{_prefix}/lib/python* 2> /dev/null || true`
50        if test -n "$badpyexecdir" ; then
51                pyexecdirver=`basename $badpyexecdir`
52                install -d -m755 $RPM_BUILD_ROOT/%{_libdir}/${pyexecdirver}
53                mv ${badpyexecdir}/site-packages $RPM_BUILD_ROOT/%{_libdir}/${pyexecdirver}/
54        fi
55fi
56
57# Remove static python modules and la files, which are probably useless to
58# Python anyway.
59rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/*.la
60rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/*.a
61
62for png in home left right up ; do
63cp %{_datadir}/gtk-doc/data/${png}.png $RPM_BUILD_ROOT/%{_datadir}/gtk-doc/html/vte/
64done
65
66%find_lang %{name}
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72%files -f %{name}.lang
73%defattr(-,root,root)
74%doc ChangeLog COPYING HACKING NEWS README doc/utmpwtmp.txt doc/boxes.txt src/iso2022.txt doc/openi18n/UTF-8.txt doc/openi18n/wrap.txt
75%{_libdir}/*.so.*
76%dir %{_libdir}/%{name}
77%attr(2711,root,utmp) %{_libdir}/%{name}/gnome-pty-helper
78%{_datadir}/%{name}
79%{_libdir}/python*/site-packages/*
80
81%files devel
82%defattr(-,root,root)
83%{_datadir}/gtk-doc/html/%{name}
84%{_includedir}/*
85%dir %{_libdir}/%{name}
86%{_libdir}/%{name}/decset
87%{_libdir}/%{name}/interpret
88%{_libdir}/%{name}/iso8859mode
89%{_libdir}/%{name}/nativeecho
90%{_libdir}/%{name}/osc
91%{_libdir}/%{name}/slowcat
92%{_libdir}/%{name}/utf8echo
93%{_libdir}/%{name}/utf8mode
94%{_libdir}/%{name}/vterdb
95%{_libdir}/%{name}/window
96%{_libdir}/*.a
97%{_libdir}/*.so
98%{_libdir}/pkgconfig/*
99
100%changelog
101* Fri Apr 30 2004 Nalin Dahyabhai <nalin@redhat.com> 0.11.11-1
102- update to 0.11.11
103
104* Mon Jun 16 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.10-2
105- rebuild
106
107* Mon Jun 16 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.10-1
108- fix vte_terminal_set_encoding() so that the Terminal/Character Coding
109  menu works in gnome-terminal again
110- fix display of the character under the cursor in cases where it's too wide
111
112* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
113- rebuilt
114
115* Mon Jun  2 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.9-2
116- rebuild
117
118* Mon Jun  2 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.9-1
119- fix saving/restoring the cursor with DECSET/DECRST
120- revert behavior wrt ambiguously-wide characters to be more like 0.10.x
121
122* Thu May 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.8-1
123- close some memory leaks
124- fix conversions of NUL bytes (Ctrl-Space)
125
126* Tue May 20 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.7-1
127- make handling of 8-bit SS2 and SS3 coexist properly with UTF-8 and other
128  encodings where valid text can't be mistaken for the control codes
129- fix keypad page down in application keypad mode
130- fix reference loop which prevented proper finalizing of the widget
131
132* Tue May  6 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.6-1
133- handle 8-bit SS2 and SS3
134- share backgrounds between terminal instances
135
136* Wed Apr 30 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.5-1
137- pick up font settings from xrdb if GTK+ doesn't know anything
138- support CP437 as a national replacement charset
139
140* Thu Apr 24 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.4-1
141- update transparent background faster when moving windows
142- fix bold
143- add an AtkComponent interface for accessibility
144
145* Thu Apr 17 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.3-1
146- rework support for national replacement charsets and iso2022
147
148* Thu Apr 17 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.2-1
149- selection tweaks and an openi18n fix
150
151* Mon Apr 14 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.1-1
152- drawing cleanups
153
154* Wed Apr  9 2003 Nalin Dahyabhai <nalin@redhat.com>
155- rework drawing with Xft2 to use font sets
156- implement drawing with freetype using font sets
157
158* Mon Feb 24 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.25-1
159- incorporate fix for issues noted by H D Moore (CAN-2003-0070)
160
161* Mon Feb 24 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.24-3
162- home the cursor when we switch to the alternate screen
163 
164* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> 0.10.24-2
165- rebuilt
166 
167* Fri Feb 21 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.24-1
168- be consistently wrong about the width of ACS characters (#84783)
169
170* Fri Feb 21 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.23-1
171- update to 0.10.23
172- don't always perform character centering
173
174* Thu Feb 20 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.22-3
175- refix ctrl-[2-8] (#83563) to not break meta variants
176
177* Thu Feb 20 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.22-2
178- stop gratuitously resetting the IM (#81542)
179- be more careful about assuming the IM exists when it might not
180
181* Thu Feb 20 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.22-1
182- be more careful about when we reset the IM (#81542)
183- always perform character centering
184- fix drawing of rows where the first exposed cell is the second half of a
185  full-width character
186
187* Wed Feb 19 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.21-1
188- report accessible focus-changed events properly
189- fix window_scroll optimization check (#83679)
190- fix ctrl-[2-8] (#83563)
191- grab focus on button 1 click (#84384)
192
193* Fri Feb 14 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.20-1
194- don't mix up maintainer mode with debugging mode
195- coalesce data reads to spare the X server from too many small updates (#83472)
196- fix backtab
197
198* Thu Feb 13 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.19-1
199- close descriptor leak
200- skip over fragments correctly when retrieving text and drawing rows
201
202* Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.18-1
203- fix for uncertain finalize order between the terminal and its accessible peer
204- always update the cursor position on accessibe-changed events so that the
205  accessibility layer doesn't ask for text past the end of the buffer
206
207* Tue Feb 04 2003 Florian La Roche <Florian.LaRoche@redhat.de>
208- add symlink to shared lib
209
210* Mon Feb  3 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.17-1
211- draw 0x2592 natively
212
213* Fri Jan 31 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.16-1
214- fix "selection always extends by default" bug
215
216* Thu Jan 30 2003 Nalin Dahyabhai <nalin@redhat.com> 0.11.0-1
217- fork stable branch
218
219* Wed Jan 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.15-1
220- make mouse modes mutually-exclusive
221- update background immediately on realize
222- fix compile error on older versions of gcc
223- fix cursor hiding
224
225* Wed Jan 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.14-1
226- fix assorted mouse event bugs
227
228* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 0.10.12-2
229- rebuilt
230 
231* Tue Jan 21 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.13-1
232- use less memory when setting up pseudo-transparent backgrounds
233
234* Mon Jan 20 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.12-1
235- fix a few accessibility bugs
236- fix colors 90-97,100-107 not bright (GNOME #103713)
237
238* Fri Jan 17 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.11-1
239- fix overzealous clearing when drawing the cursor
240
241* Tue Jan 14 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.10-1
242- add text that scrolls off of a restricted scrolling area which goes to the
243  top of the visible screen to the scrollback buffer (#75900)
244
245* Mon Jan 13 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.9-1
246- fix scrolling through the accessibility layer
247- stop heeding NumLock when mapping cursor keys
248- steal keypress events from the input method if Meta modifier is in effect
249
250* Mon Jan  6 2003 Nalin Dahyabhai <nalin@redhat.com> 0.10.8-1
251- report changes to the accessibility layer when text is removed or moved
252  around, still needs work
253- don't use XftNameUnparse, it might not always be there
254
255* Fri Dec 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.7-2
256- rebuild
257
258* Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.7-1
259- distinguish line-drawing character set code points from the same code points
260  received from the local encoding
261
262* Tue Dec 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.6-1
263- handle ambiguous-width line-drawing characters
264
265* Tue Dec 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.5-3
266- rebuild
267
268* Mon Dec  9 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.5-2
269- work around AM_PATH_PYTHON not being multilib-aware
270
271* Tue Dec  3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.5-1
272- cleaned up the keyboard
273
274* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.4-1
275- make selection wrap like XTerm
276
277* Thu Nov  7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.3-1
278- get selection sorted out, really this time
279
280* Tue Nov  5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.2-1
281- get selection sorted out
282
283* Tue Oct 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10.1-1
284- add the ability to remove matching patterns
285
286* Thu Oct 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.10-1
287- allow setting the working directory (#76529)
288
289* Thu Oct 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.2-1
290- fix the crash-on-resize bug (#75871)
291- add bold
292- implement sun/hp/legacy function key modes
293- recognize cs with no parameters
294- fix ring buffer manipulation bugs
295- cut down on overly-frequent invalidates
296
297* Wed Sep 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.1-1
298- refresh gnome-pty-helper from libzvt
299
300* Wed Sep 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.0-1
301- build fixes from Jacob Berkman
302- warning fixes from Brian Cameron
303- gnome-pty-helper integration
304
305* Fri Sep  6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.20-1
306- build fixups from Jacob Berkman
307- move the python module into the gtk-2.0 subdirectory, from James Henstridge
308
309* Thu Sep  5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.19-1
310- possible fix for focusing bugs
311
312* Thu Sep  5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.18-1
313- fix for worst-case when stripping termcap entries from Brian Cameron
314- add docs
315
316* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.17-1
317- track Xft color deallocation to prevent freeing of colors we don't own
318
319* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.16-1
320- handle color allocation failures better
321
322* Mon Sep  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.15-1
323- cleanups
324
325* Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.14-1
326- get smarter about adjusting our adjustments (#73091)
327
328* Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.13-1
329- restore the IM status window by restoring our own focus-in/focus-out
330  handlers (#72946)
331
332* Fri Aug 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-1
333- cleanups
334
335* Thu Aug 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.11-1
336- clean up autoscroll (#70481)
337- add Korean text examples to docs
338
339* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.10-1
340- autoscroll (#70481)
341- only perform cr-lf substitutions when pasting (#72639)
342- bind GDK_ISO_Left_Tab to "kB" (part of #70340)
343
344* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.9-1
345- handle forward scrolling again (#73409)
346
347* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.8-1
348- fix crashes on resize
349
350* Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com>
351- fix missing spaces on full lines
352
353* Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.7-1
354- fix deadlock when substitutions fail
355
356* Mon Aug 26 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.6-1
357- one-liner segfault bug fix
358
359* Sun Aug 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.5-1
360- fix reverse video mode, which broke during the rendering rewrite
361
362* Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.4-1
363- prevent up/UP/DO from scrolling
364- bind shift+insert to "paste PRIMARY", per xterm/kterm/hanterm
365
366* Thu Aug 22 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.3-1
367- track changes to the style's font
368- always open fonts right away so that the metric information is correct
369- make audible and visual bell independent options
370
371* Wed Aug 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.2-1
372- don't perform text substitution on text that is part of a control sequence
373
374* Tue Aug 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.1-1
375- dispose of the updated iso2022 context properly when processing incoming text
376
377* Tue Aug 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.8.0-1
378- rework font handling to use just-in-time loading
379- handle iso-2022 escape sequences, perhaps as much as they might make sense
380  in a Unicode environment
381
382* Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.4-1
383- handle massive amounts of invalid data better (the /dev/urandom case)
384- munged up patch from Owen to fix language matching
385- fix initialization of new rows when deleting lines
386
387* Mon Aug 12 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.3-1
388- more fixes for behavior when not realized
389- require bitmap-fonts
390- escape a control sequence properly
391
392* Thu Aug  8 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.2-1
393- fix cursor over reversed text
394- fix character positioning in Xft1
395- add border padding
396- fix lack of shift-in when resetting
397
398* Tue Aug  6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.1-1
399- rework rendering with Pango
400- special-case monospaced Xft1 rendering, hopefully making it faster
401- modify pasting to use carriage returns instead of linefeeds
402
403* Thu Aug  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.7.0-1
404- rework drawing to minimize round trips to the server
405
406* Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.6.0-1
407- rework parsing to use tables instead of tries
408- implement more xterm-specific behaviors
409
410* Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.4-1
411- fix default PTY size bug
412
413* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.3-1
414- open PTYs with the proper size (#69606)
415
416* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.2-1
417- fix imbalanced realize/unrealize routines causing crashes (#69605)
418
419* Thu Jul 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.1-1
420- fix a couple of scrolling artifacts
421
422* Thu Jul 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.5.0-1
423- use gunichars internally
424- scroll regions more effectively
425- implement part of set-mode/reset-mode (maybe fixes #69143)
426- fix corner case in dingus hiliting (#67930, really this time)
427
428* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 0.4.9-3
429- free trip through the build system
430
431* Tue Jul 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.9-2
432- build in different environment
433
434* Tue Jul 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.9-1
435- check for iconv failures properly and report them more aggressively
436- guess at a proper default bold color (#68965)
437
438* Mon Jul 15 2002 Nalin Dahyabhai <nalin@redhat.com>
439- cosmetic fixes
440
441* Sat Jul 13 2002 Nalin Dahyabhai <nalin@redhat.com>
442- fix segfaulting during dingus highlighting when the buffer contains non-ASCII
443  characters (#67930)
444
445* Fri Jul 12 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.8-1
446- implement BCE (#68414)
447- bind F13-F35 per termcap
448
449* Thu Jul 11 2002 Nalin Dahyabhai <nalin@redhat.com>
450- rework default color selection
451- provide a means for apps to just set the foreground/background text colors
452- don't scroll-on-keystroke when it's just alt, hyper, meta, or super (#68986)
453
454* Tue Jul  2 2002 Nalin Dahyabhai <nalin@redhat.com>
455- allow shift+click to extend the selection (re: gnome 86246)
456
457* Mon Jul  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.7-1
458- recover from encoding errors more gracefully
459
460* Mon Jul  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.6-1
461- draw unicode line-drawing characters natively
462
463* Tue Jun 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.5-1
464- don't append spaces to multicolumn characters when reading the screen's
465  contents (part of #67379)
466- fix overexpose of neighboring cells (part of #67379)
467- prevent backscroll on the alternate screen for consistency with xterm
468- bind F10 to "k;", not "k0" (#67133)
469
470* Tue Jun 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.4-1
471- clear alternate buffer when switching screens (#67094)
472- fix setting of titles, but crept in when cleaning up GIConv usage (#67236)
473
474* Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.3-1
475- correct referencing/dereferencing of I/O channels (#66248)
476- correct package description to not mention the sample app which is no longer
477  included
478
479* Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.2-1
480- fix "cursor mistakenly hidden when app exits" by making cursor visibility
481  a widget-wide (as opposed to per-screen) setting
482
483* Tue Jun 18 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.1-1
484- fix use of alternate buffer in xterm emulation mode
485
486* Fri Jun 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
487- add a means for apps to add environment variables
488
489* Fri Jun 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.30-1
490- package up the python module
491
492* Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.29-1
493- compute padding correctly
494
495* Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.28-1
496- finish merging otaylor's Xft2 patch
497
498* Mon Jun 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.27-1
499- rework accessibility
500
501* Thu Jun  6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.26-1
502- don't package up the test program
503- emit "child-exited" signals properly
504- try to allow building with either pangoxft-with-Xft1 or pangoxft-with-Xft2
505
506* Wed Jun  5 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.25-1
507- compute font widths better
508
509* Mon Jun  3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.24-1
510- tweak handling of invalid sequences again
511
512* Fri May 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.23-1
513- switch to g_convert (again?)
514- fix use of core fonts
515
516* Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.22-1
517- plug some memory leaks
518
519* Tue May 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.21-1
520- fix matching, fix async background updates
521
522* Fri May 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.20-1
523- fixes from notting and otaylor
524
525* Tue May 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.19-1
526- fixes from andersca and Hidetoshi Tajima
527
528* Thu May 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.18-1
529- finish implementing matching
530
531* Thu May 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.17-1
532- tweak finding of selected text
533
534* Wed May 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.16-1
535- hook up Insert->kI
536- convert scroll events to button 4/5 if an app wants mouse events
537- don't send drag events when apps only want click events
538- fix selection crashbug
539
540* Tue May 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.15-1
541- fix ce, implement save/restore mode
542
543* Tue May 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.14-1
544- don't draw nul chars
545
546* Mon May 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.13-1
547- fix insert mode, implement visual bells
548
549* Thu May  9 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.12-1
550- iconv and remapping from otaylor
551- implement custom tabstopping
552
553* Wed May  8 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.11-1
554- add mouse drag event handling
555
556* Mon May  6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.10-1
557- do mouse autohide and cursor switching
558
559* Mon May  6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.9-1
560- start handling mouse events
561
562* Mon May  6 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.8-1
563- handle window manipulation sequences
564
565* Fri May  3 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.7-1
566- discard invalid control sequences
567- recognize designate-??-character-set correctly
568
569* Thu May  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.6-1
570- add a couple of sequence handlers, fix a couple of accessibility crashbugs
571
572* Thu May  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.5-1
573- fix cap parsing error and "handle" long invalid multibyte sequences better
574
575* Thu May  2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.4-1
576- try to speed up sequence recognition a bit
577- disable some window_scroll speedups that appear to cause flickering
578
579* Wed May  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
580- include a small default termcap for systems without termcap files
581
582* Tue Apr 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.1-1
583- disconnect from the configure_toplevel signal at finalize-time
584
585* Tue Apr 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3-1
586- add an accessiblity object
587
588* Mon Apr 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.2.3-1
589- fix color resetting
590- fix idle handlers not being disconnected
591
592* Mon Apr 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.2.2-1
593- bug fixes
594
595* Thu Apr 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.1-1
596- finish initial packaging, start the changelog
Note: See TracBrowser for help on using the repository browser.