1 | # Note this is NOT a relocatable thing :) |
---|
2 | %define name xml-i18n-tools |
---|
3 | %define ver 0.6 |
---|
4 | %define RELEASE 0 |
---|
5 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
6 | %define prefix /usr |
---|
7 | %define sysconfdir /etc |
---|
8 | |
---|
9 | Name: %name |
---|
10 | Summary: This module contains some utility scripts and assorted auto* magic for internationalizing various kinds of XML files. |
---|
11 | Version: %ver |
---|
12 | Release: %rel |
---|
13 | Copyright: GPL |
---|
14 | Group: Development/Tools |
---|
15 | Source: %{name}-%{ver}.tar.gz |
---|
16 | URL: http://nautilus.eazel.com/ |
---|
17 | BuildRoot: /var/tmp/%{name}-%{ver}-root |
---|
18 | Docdir: %{prefix}/doc |
---|
19 | |
---|
20 | %description |
---|
21 | ** Automatically extracts translatable strings from oaf, glade, bonobo |
---|
22 | ui, nautilus theme and other XML files into the po files. |
---|
23 | |
---|
24 | ** Automatically merges translations from po files back into .oaf files |
---|
25 | (encoding to be 7-bit clean). I can also extend this merging |
---|
26 | mechanism to support other types of XML files. |
---|
27 | |
---|
28 | %package devel |
---|
29 | Summary: Libraries and include files for developing Ammonite clients |
---|
30 | Group: Development/Libraries |
---|
31 | Requires: %name = %{PACKAGE_VERSION} |
---|
32 | Obsoletes: %{name}-devel |
---|
33 | |
---|
34 | %description devel |
---|
35 | This package provides the necessary development libraries and include |
---|
36 | files to allow you to develop components that make use of the Ammonite authentication |
---|
37 | services. You will need to install this package if you intend to build Nautilus |
---|
38 | from source code. |
---|
39 | |
---|
40 | %changelog |
---|
41 | * Thu Jan 04 2000 Robin * Slomkowski <rslomkow@eazel.com> |
---|
42 | - created this thing |
---|
43 | |
---|
44 | %prep |
---|
45 | %setup |
---|
46 | |
---|
47 | %build |
---|
48 | %ifarch alpha |
---|
49 | MYARCH_FLAGS="--host=alpha-redhat-linux" |
---|
50 | %endif |
---|
51 | |
---|
52 | LC_ALL="" |
---|
53 | LINGUAS="" |
---|
54 | LANG="" |
---|
55 | export LC_ALL LINGUAS LANG |
---|
56 | |
---|
57 | CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS --prefix=%{prefix} \ |
---|
58 | --sysconfdir=%{sysconfdir} |
---|
59 | |
---|
60 | if [ "$SMP" != "" ]; then |
---|
61 | (make "MAKE=make -k -j $SMP"; exit 0) |
---|
62 | make |
---|
63 | else |
---|
64 | make |
---|
65 | fi |
---|
66 | |
---|
67 | %install |
---|
68 | [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT |
---|
69 | |
---|
70 | make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install |
---|
71 | |
---|
72 | for FILE in "$RPM_BUILD_ROOT/bin/*"; do |
---|
73 | file "$FILE" | grep -q not\ stripped && strip $FILE |
---|
74 | done |
---|
75 | |
---|
76 | %clean |
---|
77 | [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT |
---|
78 | |
---|
79 | %post |
---|
80 | |
---|
81 | %postun |
---|
82 | |
---|
83 | %files |
---|
84 | |
---|
85 | %defattr(0555, bin, bin) |
---|
86 | %{prefix}/bin/xml-i18n-extract |
---|
87 | %{prefix}/bin/xml-i18n-toolize |
---|
88 | %{prefix}/bin/xml-i18n-update |
---|
89 | %{prefix}/share/xml-i18n-tools/* |
---|
90 | |
---|
91 | %defattr (0444, bin, bin) |
---|
92 | %doc AUTHORS COPYING ChangeLog NEWS README |
---|
93 | %{prefix}/share/aclocal/*.m4 |
---|