Ticket #1093 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

wheezy no longer close enough to squeeze

Reported by: amu Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords: debian wheezy
Cc: Fixed in version:
Upstream bug:

Description

Now that  Python 2.7 is the default version in wheezy, the squeeze repository is no longer an adequate stand-in; in particular, its python-hesiod depends on python (<< 2.7). Could you please add a separate wheezy build?

Thanks!

Change History

comment:1 Changed 9 years ago by jdreed

  • Milestone changed from Precise Beta to The Distant Future

bbaren kicked off a wheezy rebuild. I don't know its status.

comment:2 Changed 9 years ago by jdreed

wheezy added to DEBIAN_CODES in r25628

comment:3 Changed 9 years ago by jdreed

This is done, modulo #1225 (lprng) and #1226 (nmh). We can attempt to fix those, or decide that wheezy is the future, and give wheezy a new printing-config that drops support on lprng, and an nmh-config that uses upstream nmh (since the mbx_close issue is moot, and we should stop our MIME patches because it's not 1995 anymore).

comment:4 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to fixed

Seeing as how having a wheezy build is better than not having one, I've finished this and moved it to production. However, debathena-nmh is still missing, so you'll need the nmh-config in bleeding until that's ACK'd and moved to dev.

comment:5 Changed 9 years ago by amu

Great, thanks!

I'm happy to confirm that the subset I've been using (-standard + -build-depends) is installable modulo the nmh issue, but did find one minor nit: -athdir and -delete are both slightly behind the corresponding squeeze packages (at 10.0.1 vs. 10.0.2 and 10.0.3 respectively). Could you please build the current versions when you get a chance?

comment:6 Changed 9 years ago by jdreed

athdir and delete are now up to date.

Note: See TracTickets for help on using tickets.