Ticket #1235 (closed defect: fixed)

Opened 9 years ago

Last modified 8 years ago

tellme's usage message should use basename $0

Reported by: jmorzins Owned by:
Priority: low Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version: 1.49
Upstream bug:

Description

If a user runs "tellme" without any argument, the usage message that prints onscreen is confusing

The usage message uses echo "$0", but $0 is a very long path to the tellme script, which makes it hard to notice the root|combo|nmccombo options at the end.

Example:

$ tellme
Usage: /afs/athena.mit.edu/system/config/tellme/arch/i386_rhel4/bin/tellme root|combo|nmccombo
Where:

root - tell me the Athena root password.
combo - tell me the Athena Cluster combination.
nmccombo - tell me the New Media Center combination.

The problem is that the tellme script in /usr/bin execs the actual tellme script from /afs/athena.mit.edu/system/config/tellme/arch/i386_rhel4/bin/tellme

It could be fixed by using basename to get just the base program from $0

Attachments

tellme.patch Download (442 bytes) - added by jmorzins 9 years ago.
Patch for tellme

Change History

Changed 9 years ago by jmorzins

Patch for tellme

comment:1 Changed 8 years ago by jweiss

  • Status changed from new to closed
  • Fixed in version set to 1.49
  • Resolution set to fixed

fixed while I was there to add the new fall combo

Note: See TracTickets for help on using tickets.