Ticket #1266 (closed defect: worksforme)

Opened 9 years ago

Last modified 7 years ago

lightdm-greeter sometimes spins on get_authenticated_user()

Reported by: jdreed Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Hotline and anecdotal information has suggested that there's some new failure mode, whereby machines come up fine, but attempting to log in causes the greeter to spin. However, networking clearly works. I'll note that a new dbus and a new bind9 showed up fairly recently, and I'm inclined to think that accountservice (started via Dbus) is not starting soon enough, or something, since subsequent attempts work. I initially thought this might be #1259, but now I'm not so sure.

 LP:996791 shares some of these symptoms, and lightdm.log is complaining about FindUserByName?

Change History

comment:1 Changed 9 years ago by jdreed

OK, there's some race condition here. I managed to trigger it once on my VM, but of course we lock down cluster machines so well that I couldn't get in to debug anything. This does seem to depend on when accountsservice starts, and may be compounded that accountsservice is trying to do some operation on a user's homedir before AFS is up?

comment:2 Changed 9 years ago by jdreed

I'm not convinced bind9 or resolvconf isn't uninvolved here, either. I triggered the bug and went into kiosk browser mode, and it sat there for a good 30 seconds trying to resolve google.com. I eventually got to the page, and then logins worked fine. So, I dunno.

comment:3 Changed 9 years ago by jdreed

OK, I consider myself mystified, and am leaning towards blaming NSS (or maybe PAM) here, though I haven't entirely ruled out DBus. I have followed the code path in lightdm and accountsservice, and cannot see anything that would block on its own. Furthermore, it's not accountsservice failing to start, becuse under that circumstance, lightdm blocks for 30 seconds displaying the greeter window at all, and if accountsservice is killed after lightdm is running, then you can still log in just fine. The greeter is blocking on the get_authenticated_user call when this happens. I can remove that and some sanity checking, but I'd rather not take that step, especially since I cannot consistently reproduce this.

comment:4 Changed 8 years ago by jdreed

  • Priority changed from blocker to normal
  • Summary changed from Flaky login issues to lightdm-greeter sometimes spins on get_authenticated_user()
  • Milestone changed from Quantal Quetzal to The Distant Future

I can't repro this and am going to move its priority down and also pretend that lightdm-config 1.9 fixes this with the AFS check.

comment:5 Changed 7 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.