Ticket #1332 (closed defect: wontfix)

Opened 9 years ago

Last modified 7 years ago

c-p-d 5.x broke divert.mk

Reported by: jdreed Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

It was apparently supposed to be the case that you could just include divert.mk if you just needed the low-level functionality, and not config-package.mk. As far as I can tell, this was undocumented. We used it in 3 packages, which have now been fixed (#1328). We should either document that we broke this, or ship a stub divert.mk with a wildcard target which yells at you and then includes displace.mk. Or decide we don't care.

Change History

comment:1 Changed 7 years ago by geofft

divert.mk used to say

# Don't include divert.mk in your rules files directly; instead use
# config-package.mk.

(displace.mk now says the equivalent.) So I'd like to WONTFIX this. If you were using undocumented API, you can either declare a build-dep of config-package-dev (<< 5) or fix your packages.

comment:2 Changed 7 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.