Ticket #1435 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

lucid and squeeze broke with debathena-ssh-client-config

Reported by: jweiss Owned by: jdreed
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

peter-petrelli:~: ssh -l root tla
/etc/ssh/ssh_config line 52: garbage at end of line; "/etc/ssh/ssh_known_hosts2".
Exit 255

peter-petrelli:~: tail -1 /etc/ssh/ssh_config

GlobalKnownHostsFile? /etc/ssh/ssh_known_hosts /etc/ssh/ssh_known_hosts2 /etc/ssh/ssh_known_hosts.debathena

peter-petrelli:~: ls -l /etc/ssh/ssh_known_hosts /etc/ssh/ssh_known_hosts2 /etc/ssh/ssh_known_hosts.debathena
ls: cannot access /etc/ssh/ssh_known_hosts: No such file or directory
ls: cannot access /etc/ssh/ssh_known_hosts2: No such file or directory
-rw-r--r-- 1 root root 4421 2014-02-04 00:45 /etc/ssh/ssh_known_hosts.debathena
Exit 2

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by jdreed

I cannot reproduce this on precise, though I'll note that in my ssh_config has that line at line 53, not 52. Is this precise, or something else? Can you put your entire /etc/ssh/ssh_config somewhere, and also confirm that it is symlinked to /etc/ssh/ssh_config.debathena, and run "debsums -a debathena-ssh-client-config"?

comment:2 in reply to: ↑ 1 Changed 7 years ago by jweiss

This is Lucid.

peter-petrelli:~$ ls -l /etc/ssh/ssh_config
lrwxrwxrwx 1 root root 20 2011-03-18 14:37 /etc/ssh/ssh_config -> ssh_config.debathena
root@peter-petrelli:~# debsums -a debathena-ssh-client-config
/usr/share/doc/debathena-ssh-client-config/changelog.gz OK
/usr/share/doc/debathena-ssh-client-config/copyright OK
/etc/ssh/ssh_known_hosts.debathena OK
/etc/ssh/ssh_config.debathena OK

Actually, comparing the Precise ssh_config manpage:

GlobalKnownHostsFile?

Specifies one or more files to use for the global host key data‐
base, separated by whitespace. The default is
/etc/ssh/ssh_known_hosts, /etc/ssh/ssh_known_hosts2.

with the Lucid manpage

GlobalKnownHostsFile?

Specifies a file to use for the global host key database instead
of /etc/ssh/ssh_known_hosts.

Highlights the problem.

Indeed, removing all but one file from this line on my Lucid machine fixes this.

comment:3 Changed 7 years ago by jdreed

  • Owner set to jdreed
  • Status changed from new to accepted
  • Summary changed from ssh issues to lucid and squeeze broke with debathena-ssh-client-config

Yeah, the ability to specify multiple GlobalKnownHosts? files was added in May 2011. I'll rebuild the previous release and push it out for lucid and squeeze users.

comment:4 Changed 7 years ago by jdreed

  • Status changed from accepted to development

comment:5 follow-up: ↓ 6 Changed 7 years ago by jdreed

Jonathon, can you please take the version in -development and let me know if this fixes your problem.

comment:6 in reply to: ↑ 5 Changed 7 years ago by jweiss

Replying to jdreed:

Jonathon, can you please take the version in -development and let me know if this fixes your problem.

Sure, though I can't promise how quickly. Also, can you give me some quick instructions for how to do this?

comment:7 Changed 7 years ago by jdreed

  • Status changed from development to proposed

Since this is actively biting users, I've tested it and will push to proposed. On Lucid, ssh works again, and on Precise, I still get KeyEx? disabled, but also get the debathena known_hosts.

comment:8 Changed 7 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.