Ticket #1468 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

devscripts-el cannot be installed in the same transaction as emacs

Reported by: jdreed Owned by:
Priority: high Milestone: Current Semester
Component: -- Keywords:
Cc: Fixed in version: debathena-debian-dev 0.6
Upstream bug:  LP:1322260

Description

We should consider not requiring them for Debathena. (It was possibly a mistake to require debathena-debian-dev.)

The exact cause of the failure is unclear but based on Debian 734531 et al, it seems like it's a poor interaction between emacsen-common 2.0.6+ and dh_installemacsen in dh9.

Change History

comment:1 Changed 7 years ago by jdreed

Installing emacs24 (and thus emacsen-common) _before_ installing workstation fixes ("fixes") this. It's unclear if we should pre-depend on emacs, or just punt debathena-debian-dev from extra-software and assume that nobody is building debian packages besides us, or what.

comment:2 Changed 7 years ago by jdreed

  • Upstream bug set to LP:1322260
  • Summary changed from dpkg-dev-el and devscripts-el are flaky to devscripts-el cannot be installed in the same transaction as emacs

comment:4 Changed 7 years ago by jdreed

  • Status changed from new to development
  • Fixed in version set to debathena-debian-dev 0.6

comment:5 Changed 7 years ago by jdreed

  • Status changed from development to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.