Ticket #1543 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

debathena-machtype should not depend openafs-client

Reported by: andersk Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version: debathena-machtype 10.5.4
Upstream bug:

Description

debathena-machtype 10.5 changed the build dependency on openafs-client to a runtime dependency. This makes it impossible to install debathena-clients without openafs-client, which used to work.

Change History

comment:1 Changed 6 years ago by andersk

Even worse, debathena-clients now pulls in openafs-client without debathena-afs-config, which isn’t what anyone wants.

comment:2 Changed 6 years ago by jdreed

  • Status changed from new to review

comment:3 Changed 6 years ago by jdreed

  • Status changed from review to committed

committed  5768338851f1a927930f467aa3dacd4cdf92f836 (Make openafs-client a build-dep, not a runtime dep) to master

comment:4 Changed 6 years ago by jdreed

  • Status changed from committed to proposed

comment:5 Changed 5 years ago by andersk

  • Fixed in version set to debathena-machtype 10.5.4

comment:6 Changed 5 years ago by andersk

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.