Ticket #1554 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

debathena-lightdm-config fails to install on non-Upstart systems

Reported by: andersk Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version: debathena-lightdm-config 1.13.3
Upstream bug:

Description

After commenting # I hope this doesn't break the world., debathena-lightdm-config.postinst invokes initctl unconditionally, thereby breaking the world on systems without Upstart (Debian and vivid).

Setting up debathena-lightdm-config (1.13.2~debian8.0~0.2) ...
/var/lib/dpkg/info/debathena-lightdm-config.postinst: 208: /var/lib/dpkg/info/debathena-lightdm-config.postinst: initctl: not found
dpkg: error processing package debathena-lightdm-config (--configure):
 subprocess installed post-installation script returned error exit status 127

Change History

comment:1 Changed 6 years ago by slz

I can confirm that this is the case on a fresh Ubuntu Vivid install on nucular-jukebox. We definitely want this fixed before 16.04 comes around.

slz@nucular-jukebox:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up debathena-lightdm-config (1.13.2~ubuntu15.04~0.1) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package debathena-lightdm-config (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of debathena-login-graphical:
 debathena-login-graphical depends on debathena-lightdm-config; however:
  Package debathena-lightdm-config is not configured yet.

dpkg: error processing package debathena-login-graphical (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 debathena-lightdm-config
 debathena-login-graphical
E: Sub-process /usr/bin/dpkg returned an error code (1)

comment:2 Changed 4 years ago by slz

  • Status changed from new to committed

committed  1c855afed44ee4b17fd54d2d3077838888641be6 (Make postinst install on systemd systems by ignoring errors) to master

comment:3 Changed 4 years ago by andersk

  • Status changed from committed to proposed
  • Fixed in version set to debathena-lightdm-config 1.13.3

comment:4 Changed 4 years ago by andersk

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.