Ticket #1591 (new defect)

Opened 3 years ago

debathena-archive-keyring uses apt-key without depending on gnupg or gnupg2

Reported by: andersk Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

$ sudo apt install debathena-archive-keyring
[…]
Setting up debathena-archive-keyring (1.5~ubuntu17.04~0.1) ...
Warning: The postinst maintainerscript of the package debathena-archive-keyring
Warning: seems to use apt-key (provided by apt) without depending on gnupg or gnupg2.
Warning: This will BREAK in the future and should be fixed by the package maintainer(s).
Note: Check first if apt-key functionality is needed at all - it probably isn't!
Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package debathena-archive-keyring)

We should probably fix this by migrating to /etc/apt/trusted.gpg.d (like debian-archive-keyring and ubuntu-keyring did).

Note: See TracTickets for help on using tickets.