Ticket #188 (closed enhancement: fixed)

Opened 13 years ago

Last modified 12 years ago

<Tab> doesn't switch from username to password field on login screen

Reported by: adehnert Owned by: adehnert
Priority: trivial Milestone:
Component: -- Keywords: gdm
Cc: Fixed in version:
Upstream bug:

Description

The Ubuntu theme lets you use the tab key to switch between the username and password fields. Debathena cluster (or workstation, or something) machines don't seem to do this. It would be cool if they did.

Attachments

debathena.tar.gz Download (229.8 KB) - added by jmorzins 12 years ago.
"fixed" debathena theme

Change History

comment:1 Changed 13 years ago by mitchb

Actually, it's tabbing "just fine." What really happens is that
the first time you hit tab, it moves to the Session button, the
next time you do it, it goes to the Action button, and then when
you hit it again, it *does* advance to the Password field.
Similarly, if you hit tab at that point, you go to Session, then
Action, and finally you attempt to log in.

So, it seems like the problem is more in the ordering of the
fields for selection than the behavior. However, I sort of think
it's very nonintuitive for Tab to

o Take you to a field that wasn't even visible on your screen

to start with

o Submit anything as if you'd hit Enter (yes, if you type your

username, 3xTab, password, 3xTab, you're logged in without
ever having hit Enter or clicked anywhere)

comment:2 Changed 13 years ago by xavid

I've heard from several people who are used to using tab to submit their username in Athena 9, so while it does seem unintuitive to me, if people are used to it and it's easy to have work, we should probably make it work.

comment:3 Changed 12 years ago by adehnert

For reference:

-> sipb / debathena / jmorzins  11:37  (Jacob Morzinski)
       I figured out why Tab on the debathena login page cycles through
       the action/session buttons, which is different from how tab on the
       default ubuntu login page switches to prompting for a password.
   
       It's because the debathena login theme actually uses buttons,
       while the default ubuntu login theme has no buttons.  (The widget
       that looks like a button is actually just a text label that changes
       color if you hover over it.)
   
       So... poop.  I guess we could fix the debathena login page if we
       replaced the buttons with pixmaps, though I wish I knew more
       about gtk... maybe there's a way to keep buttons but disable tabbing.

Changed 12 years ago by jmorzins

"fixed" debathena theme

comment:4 Changed 12 years ago by jmorzins

I've edited the debathena theme to use pixmaps and text labels, instead of using buttons.
The pixmaps look a lot like buttons but aren't actually buttons, so you can't tab onto them.

I've attached the resulting theme to this ticket as a tar.gz file.
You can remove (or move aside) your current debathena theme from /usr/share/gdm/themes and replace it with the tar file.

The tar file contains all files of the debathena directory. The new/changed files are:
debathena.xml - written to use pixmaps and text labels for the Session and Actions button, which fixes the tab problem.
btn-normal.svg - a fake background for the "normal" button state
btn-prelight.svg - a fake background for the "hover" button state
btn-active.svg - a fake background for the "active" button state
screenshot.png - an up-to-date screenshot

comment:5 Changed 12 years ago by broder

  • Status changed from new to proposed

Thanks for putting the work into this, Jacob.

I've uploaded a new version of the debathena-gdm-config package with your theme changes to the proposed repository (see http://debathena.mit.edu/experimental#proposed).

I'll plan to move this change to production after 2 days and after verification that the fix works.

comment:6 Changed 12 years ago by quentin

I just took this update on opus and it appears to work as advertised; the tab key works to move from the username field to the password field, and the buttons still bring up their respective menus. The keyboard shortcuts for the menus also still work. Good work!

comment:7 Changed 12 years ago by broder

  • Status changed from proposed to closed
  • Resolution set to fixed

The fix is now in production.

Note: See TracTickets for help on using tickets.