Ticket #219 (closed task: fixed)

Opened 12 years ago

Last modified 12 years ago

Document the brokenness of binaries linked against /lib/ld-linux.so.1

Reported by: jdreed Owned by: jdreed
Priority: normal Milestone: Fall 2009 Release
Component: documentation Keywords:
Cc: Fixed in version:
Upstream bug:  LP:335666

Description

See ATN-41 for details. Running old binaries (ez, for example) produces the incorrect error message "command not found", when what it really can't find is the interpreter. We should document this, and possible provide something like "athrun consult checkbinary" or maybe just "strings foo | grep -i ld-linux.so.1"

Also see LP335666 for the upstream bug.

Change History

comment:1 Changed 12 years ago by jdreed

  • Upstream bug set to https://bugs.launchpad.net/bugs/335666

As per the comment on LP335666, we should try and get this upstream into the kernel.

comment:2 Changed 12 years ago by broder

  • Upstream bug changed from https://bugs.launchpad.net/bugs/335666 to LP:335666

comment:3 Changed 12 years ago by jdreed

Documentation done and in Hermes.

I'm going to change the metadata for this to more accurately reflect what we need to do.

We should decide if we still care enough to try and get LP335666 into the kernel. I'm willing to bet we're the only site that still has a bunch of libc5 binaries lying around for people to trip over. I'd rather spend the time and effort in desupporting ancient lockers.

comment:4 Changed 12 years ago by broder

Not true, actually. I ran into this bug (or something very like it) when I was working on a cross-compiler toolchain for my phone. Long story, but the short version is that I found the pre-built compiler that Palm was supposedly using, and I was getting ENOENTs when I tried to run them on my Jaunty VM. So I think this is still worth pushing, but through kernel.org, not through LP.

comment:5 Changed 12 years ago by geofft

  • Status changed from new to assigned

jdreed said he'll take care of documenting this for fall release, although we should still get this fixed in the kernel or something as a good deed to the world.

comment:6 Changed 12 years ago by jdreed

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.