Ticket #236 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

erlang-base conflicts erlang-doc-html on jaunty

Reported by: broder Owned by: broder
Priority: low Milestone: Upstream Utopia
Component: upstream Keywords:
Cc: Fixed in version:
Upstream bug:  LP:371581

Description

erlang-base conflicts with erlang-doc-html (<< ${Upstream-Version}), even though erlang-doc-html is a completely separate source package. It's a cute trick, so long as the two packages stay in sync.

Unfortunately, erlang-base was manually synced into Jaunty after the DebianImportFreeze?, and nobody thought to grab erlang-doc-html as well.

This makes the two uninstallable, which means that thirdparty also won't currently install on Jaunty.

I see two options:

  • SRU for erlang-base removing the conflict
  • SRU for erlang-doc-html syncing in the new upstream version.

I don't know which is more likely to happen in bounded time. In the mean time, we should make erlang-doc-html a recommendation of thirdparty-languages instead of a dependency.

Change History

comment:1 Changed 12 years ago by broder

  • Owner set to broder
  • Status changed from new to accepted
  • Upstream bug set to LP:371581

Filed  LP:371581

comment:2 Changed 12 years ago by broder

  • Status changed from accepted to proposed

For the time being, I've made erlang-doc-html a recommendation of debathena-thirdparty-languages. We can move it back to a dependency when the issue is fixed in Jaunty.

Fix is in proposed; I'll move to production on Wednesday.

comment:3 Changed 12 years ago by broder

  • Status changed from proposed to accepted

The change to thirdparty was moved into production a while ago. I'll keep the ticket open to track the issue in Ubuntu.

comment:4 Changed 12 years ago by broder

  • Priority changed from major to minor
  • Component changed from -- to upstream

comment:5 Changed 12 years ago by jdreed

  • Milestone set to Upstream Utopia

comment:6 Changed 12 years ago by broder

  • Status changed from accepted to closed
  • Resolution set to fixed

I'm not really seeing any pressure to fix this, so I'm going to FIXRELEASE it, on the grounds that we worked around the bug.

Note: See TracTickets for help on using tickets.