Ticket #291 (closed enhancement: wontfix)

Opened 12 years ago

Last modified 12 years ago

mail-icon-config should know about some common external mail providers

Reported by: broder Owned by:
Priority: low Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Now that we have email-icon-config, it would be a really cool enhancement to teach it about some of the common places that people chpobox their mail to. For example, if you're chpoboxed to Gmail, it would be cool for the e-mail icon to pull up a browser sending you to Gmail.

Change History

comment:1 in reply to: ↑ description Changed 12 years ago by broder

Replying to jweiss:

The problem is that hesinfo won't report foreign mailboxes, just what
your loval mailbox is, evein if your mail isn't going to it, and
realtime moira queries are a bad idea.

Yeah, that is problematic, and I haven't figured out the perfect workaround yet. We also want to be careful to not make it too easy for people to find a list of e-mail addresses of all Athena users, so we have to be careful there.

My best idea currently is to run a DCM into a remctl server such that something like remctl poboxes email $USER prints out the user's actual e-mail address, and then we parse from there. Either only let people query for their own username, or just require it to be Kerberos authed (which is probably good enough deterrence, since the remctl setup/teardown is slower than the equivalent Moira lookup).

The requirement of an additional server is kind of unfortunate, though, so I'm interested in hearing other ideas for where we can stuff the data.

comment:2 Changed 12 years ago by broder

  • Status changed from new to closed
  • Resolution set to wontfix

I think the general conclusion here was that this would be a completely non-discoverable feature, and probably confusing at best.

Note: See TracTickets for help on using tickets.