Ticket #307 (closed defect: duplicate)

Opened 12 years ago

Last modified 11 years ago

the non-gdm tty "press ctrl-alt-f7 to log in" messages are gone in Jaunty

Reported by: amb Owned by: broder
Priority: low Milestone: Summer 2010 (Lucid Deploy)
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:  LP:367812

Description

This used to work under intrepid. It's probably something trivial.

Change History

comment:1 Changed 12 years ago by broder

I tried adding the ttymsg upstart job to my (non-Debathena) Jaunty VM and rebooting, and the message showed up fine. It also did when I rebooted debathena-install-test.

geofft suggested that logging in/out or using the kiosk browser might be triggering this - i.e. that something is clearing the ttys. That would mean that we'd need some way to trigger a job when gdm restarted - I don't know how to do that.

If somebody with a more capable testing environment than me could figure out some way to cause this to happen reproducibly, that'd put us in a better place to fix it.

comment:2 Changed 12 years ago by rbasch

I did some testing on a cluster machine. A kiosk session used tty1 (it uses the first available VT), and some diagnostic output clobbered the ttymsg message. But I also noticed that tty2 was blank, so I think something else must have allocated it; the ttymsg message appeared on ttys 3-6.

I will change the kiosk script to not use these VTs. We might also want to think about changing the ttymsg job to keep ttys 1-6 open, so that openvt (or whatever) will not allocate them.

comment:3 Changed 12 years ago by broder

  • Status changed from new to development

It seems that nobody is really sure how either openvt or upstart works. But if I'm right, r23960 should spawn a long-running daemon that holds open fds on /dev/tty[1-6], which should in turn prevent openvt from picking them.

Alternatively, it could just break anything. It's always hard to tell with these things.

For the time being, I've only uploaded the package to -development; I'll move it to -proposed when I know that it won't break the world.

comment:4 Changed 12 years ago by geofft

  • Status changed from development to assigned
  • Owner set to broder

It doesn't break anything, but it also doesn't work at all. Curiously, tty8 is also empty on the machines I looked at (three HPs), regardless of whether or not it has this version of cluster-login-config

comment:5 Changed 12 years ago by broder

  • Status changed from assigned to closed
  • Resolution set to fixed

I haven't been able to reproduce this on either opus or one of the cluster machines in W20. If someone else can, they should feel free to reopen the ticket, but I'm pretty sure the Python script is working as intended.

comment:6 Changed 12 years ago by geofft

  • Status changed from closed to reopened
  • Resolution fixed deleted
  1. This affects gettys as well (I'm running a getty on lola-granola's tty1), so it's not something silly we're doing with our script. You can type into the hidden login prompt and log in, but you see no feedback.
  1. I can reproduce this on lola-granola after a kexec (and not before); that's probably the connection we were missing.

comment:7 Changed 12 years ago by geofft

  • Upstream bug set to LP:367812

comment:8 follow-up: ↓ 9 Changed 12 years ago by jdreed

In the short term, can we turn off kexec on -cluster?

ISTR that when it was thrust upon all Jaunty users, we decided it was a "feature", since it made reboots much faster if they were triggered by the reactivate script. Now that we do a better job of really killing off processes in the chroot, reboots are far less likely.

I'll note that we reference the "Press ctrl-alt-F7 to login" messages a bit in documentation, so it'd be nice if they were there, but if it's better to wait for an upstream fix rather than turning off kexec, that's probably fine. Though presumably this will also screw us when we implement P or tty-in-an-xterm (which, by the way, was a popular request at a help desk student training meeting on Tuesday).

comment:9 in reply to: ↑ 8 Changed 12 years ago by jdreed

Argh, screwed by wiki formatting.

"...when we implement Ctrl-P or tty-in-an-xterm..."

comment:10 Changed 11 years ago by jdreed

  • Status changed from reopened to closed
  • Resolution set to duplicate

This is #496

Note: See TracTickets for help on using tickets.