Ticket #341 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

WINDOW_MANAGER isn't respected in Jaunty

Reported by: geofft Owned by: jdreed
Priority: normal Milestone: Fall 2009 Release
Component: documentation Keywords:
Cc: Fixed in version:
Upstream bug:

Description

My .bash_environment contains in part:

add windowmanagers
export WINDOW_MANAGER=ratpoison
skip_panel=1
skip_nautilus=1
skip_initial_xterm=1

This suffices to get me ratpoison on -cluster and below on Intrepid (and on Athena 9), but not on Jaunty. I've also heard reports from others that WINDOW_MANAGER doesn't work for them.

Since it works on up-to-date Intrepid systems, this is something Ubuntu changed; we should figure out what it is and work around it.

Change History

comment:1 Changed 12 years ago by jdreed

I'm fairly certain we decided way back when to stop supporting WINDOW_MANAGER as part of desupporting legacy Athena 9 stuff. The fact that it worked in Intrepid was not by design. If upstream Ubuntu isn't supporting it, we shouldn't either. I believe we decided that people who want custom WMs get to write their own Xsessions.

comment:2 Changed 12 years ago by broder

Hmm..I bet this just has to do with when your dotfiles get sourced. Based on  Xmonad docs, it sounds like WINDOW_MANAGER works if it gets set before gnome-session runs.

So maybe bash_environment was getting sourced sometime early in the login process before, and it's not anymore?

In any case, both the .gnomerc and custom .xsession scripts look very simple to write, if they work, so this might be more simply dealt with as a documentation problem.

comment:3 Changed 12 years ago by jdreed

  • Owner set to jdreed
  • Status changed from new to accepted
  • Component changed from -- to documentation

comment:4 Changed 12 years ago by jdreed

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.