Ticket #409 (closed enhancement: wontfix)

Opened 12 years ago

Last modified 7 years ago

ood-packages shouldn't require you to be debathena-root to work

Reported by: geofft Owned by:
Priority: trivial Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

There's a script "ood-packages" in the debathena locker that will give you a list of all packages with newer versions in SVN than in apt. It uses reprepro, which wants to be able to lock the apt repo while running, and therefore requires write bits on the apt repo. I'd probably use it more if I could run it unprivileged.

Change History

comment:1 Changed 12 years ago by broder

While you're looking at ood-packages, it'd be nice if it did something more clever with -proposed than it does currently (i.e. ignores it)

comment:2 Changed 11 years ago by broder

For what it's worth, I just looked at trying to do this by telling reprepro to not error out if it can't get a lock, but that's not possible with the code as it stands - an error in acquiring the lock immediately bubbles up all the way to main().

It looks like if we actually want to fix this, we'll need to use something other than reprepro to get current package information - grep-dctrl, maybe?

comment:3 Changed 11 years ago by jdreed

  • Milestone set to The Distant Future

comment:4 Changed 7 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.