Ticket #457 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

force logout of abandoned cluster causes greyout

Reported by: afarrell Owned by: geofft
Priority: blocker Milestone: Spring 2010
Component: login chroot Keywords: greyout force-logout ctrl-L
Cc: Fixed in version:
Upstream bug:

Description

After trying to force logout a user who has been away yet logged in for a significant amount of time, the screen turns light grey and the fan begins overspinning.

Change History

comment:1 Changed 12 years ago by broder

From my uninformed perspective, this sounds like a dupe of #278. Is it not?

comment:2 Changed 12 years ago by jdreed

It's not clear that it's a dupe -- the fan behavior is new (at least to me). If the fan suddenly goes insane on the newer Dells, that's probably because both cores are at 100% usage. I'd blame the ATI drivers (I saw similar behavior when I got bitten by  LP:366687), but we're not using them.

Alternatively, the fan does spin loudly just before system halt and at reboot time. So it's possibly we're seeing something else. I kind of want to see this in the field -- I'll try and reproduce on Monday.

I'm assuming this is a Dell 745 or newer. If it's a 620 or a 5100, then, uh, that's weird.

comment:3 Changed 12 years ago by jdreed

  • Milestone set to Spring 2010

At 1/29 release-team, we agreed to make the screensaver logout command more ... insistent, probably by supplying --force to the gnome-session-mumble command. If need be, we can take drastic measures like HUP Xorg or something, since we have always said that if you're force-logged out, you can and will lose all unsaved work. But we do need to cleanup gracefully from the chroot.

comment:4 Changed 12 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to fixed

I finally encountered such a machine today, and after force-logging out a user, I got back to a login screen in about 10 seconds.

So I think the --force change fixed this.

Note: See TracTickets for help on using tickets.