Ticket #459 (closed defect: duplicate)

Opened 11 years ago

Last modified 11 years ago

alpine should respect ATHENA_USER as FROM address

Reported by: adehnert Owned by:
Priority: normal Milestone:
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

When you run Alpine on a machine where your local user is differently named from your Athena user, Alpine should somehow be configured to send mail from $ATHENA_USER@…, not $USER@…. Unfortunately, this seems mildly difficult, since Alpine doesn't appear to directly provide a way set the user part of the sender (and appears to use /etc/passwd or something, not $USER, to get username information).

You can sort of handle this by adding alt-addresses=$ATHENA_USER@… in the pinerc, and by adding a default role that sets the from address to $ATHENA_USER@… (see  http://mailman2.u.washington.edu/pipermail/alpine-info/2009-January/001606.html). (This does seem somewhat kludgy, and will cause mail to/from $USER@… to appear to/from you.)

Change History

comment:1 Changed 11 years ago by andersk

  • Status changed from new to closed
  • Resolution set to duplicate

Dupe of #422.

Note: See TracTickets for help on using tickets.