Ticket #467 (closed defect: duplicate)

Opened 12 years ago

Last modified 12 years ago

Unclean shutdown of reactivate-2 causes time-consuming schroot cleanup

Reported by: jdreed Owned by:
Priority: low Milestone: Summer 2010 (Lucid Deploy)
Component: login chroot Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Rebooting an uncleanly shutdown reactivate-2 machine causes it to attempt to recover schroot sessions. Recovery fails because the directory /var/lib/schroot/union/overlay/login-{$uuid} does not exist, but it's still somewhat time consuming to do this on a slower (620, HP) machine. Can we skip this step, since presumably we never care about recovering schroot sessions on cluster machines?

Change History

comment:1 Changed 12 years ago by jdreed

Indeed we can, by setting RECOVER_SESSIONS="end" in /etc/schroot/default.

We should do that.

comment:2 Changed 12 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to duplicate

Dupe of #451, closing.

Note: See TracTickets for help on using tickets.