Ticket #475 (closed task: fixed)

Opened 12 years ago

Last modified 11 years ago

Talk to save about de-supporting "setup save" and nuking most of /mit/save/bin

Reported by: jdreed Owned by: jdreed
Priority: normal Milestone: Summer 2010 (Lucid Deploy)
Component: printing Keywords:
Cc: Fixed in version:
Upstream bug:

Description

"setup save" only works for tcsh users, and makes all kinds of assumptions about our printing infrastructure. /mit/save/bin is full of bitrotted csh scripts and old copies of "lpr2" which are actively harmful these days.

We should talk to save about desupporting "setup save" and nuking most of /mit/save/bin. If there's any functionality that's missing after the cleanup, we can talk about providing it in Debathena directly.

Change History

comment:1 Changed 12 years ago by jdreed

  • Status changed from new to accepted

SAVE mostly no longer exists, AfAICT. But I have sent mail to the locker ACL and we'll see what happens.

comment:2 Changed 12 years ago by jdreed

Mail to the locker acl got a very nice response from someone from the class of 2002 saying that she wasn't at MIT anymore and that was about it.

Mail to sustainability@MIT located one of SAVE's last officers who says:

"Looking back to the original e-mail thread, I think it is fine for IS&T remove those programs from the SAVE locker, if they have the ability to do that. "

I confirmed with her, and will deal with the locker with my accounts hat on (and will forward the relevant e-mail thread to RT for completeness)

comment:3 Changed 12 years ago by jdreed

Actually, it turns out we don't have to do anything too intrusive, because the locker has sufficiently bitrotted that the newsest arch it has is i386_linux3.

We can just move the .attachrc aside, and create i386_rhel4 and i386_deb40 directories, and put a script in there that will complain at the user, and provide symlinks to that script from all the command names used by save.

comment:4 Changed 12 years ago by jdreed

Done. "setup save" now politely tells users to go look at web/printing/environment/ (currently a redirect to Hermes) instead.

At some point next week, I'll move /mit/save/arch/i386_rhel4.new to /mit/save/arch/i386_rhel4.

Now would be the time to comment if anything is wrong with this plan.

comment:5 Changed 11 years ago by jdreed

  • Status changed from accepted to closed
  • Resolution set to fixed

Changed on 4/5. No one has complained yet.

Note: See TracTickets for help on using tickets.