Ticket #666 (closed task: fixed)

Opened 11 years ago

Last modified 11 years ago

Ask mirrors.mit.edu maintainers to upgrade lighttpd

Reported by: jdreed Owned by: geofft
Priority: normal Milestone: Fall 2010
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Geoff notes that Anders directed us to:

 http://redmine.lighttpd.net/issues/657

Quoting from the bug, the reporter points out a workaround in apt
documented as
"A value of zero MUST be specified if the remote host does not
properly linger on TCP connections - otherwise data corruption will
occur. Hosts which require this are in violation of RFC 2068."

We believe this to be the cause of the transient installer failures.

Change History

comment:1 Changed 11 years ago by geofft

  • Status changed from new to accepted
  • Owner set to geofft

 LP:611256 reproduces this and claims that the bug is still present on Lucid (which has a fixed lighttpd) -- I've replied asking if that means when installing Lucid against a mirror with an older lighttpd, or when running Lucid on the mirror.

I've talked to ismith and will be providing him with a patched lighttpd, and he says he'll upgrade mirrors.mit.edu from Jaunty to Lucid this weekend.

comment:2 Changed 11 years ago by geofft

Ian's installed the patched lighttpd (see  https://debathena.mit.edu/for_mirrors/, which I will probably take down in a few days) and I'm kicking off four VM installs. We'll see if they work, at which point I would be inclined to say that this is fixed.

So far the only hang is on security.ubuntu.com...

comment:3 Changed 11 years ago by amb

  • Status changed from accepted to closed
  • Resolution set to fixed

No problems with mirrors.mit.edu have been noted recently, so yay.

Note: See TracTickets for help on using tickets.