Ticket #678 (closed defect: ignored)

Opened 11 years ago

Last modified 11 years ago

Debian's clisp-dev has dumb dependencies

Reported by: geofft Owned by:
Priority: normal Milestone: Natty Alpha
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:  DebianBug:177057,  DebianBug:504514

Description

 clisp-dev is a Recommendation of debathena-thirdparty-languages, and it's not installing on Lucid because it has a hard dependency on libreadline5-dev, and everyone else is using libreadline6-dev, which conflicts (there are exactly two other packages in the archive that depend on libreadline5-dev and don't permit libreadline6-dev as an alternative). I'm pretty sure there's no good reason for this.

Furthermore, as pointed out by  DebianBug:504514,

Depends: clisp, libc6-dev, debhelper (>> 7), gettext, bison, libncurses5-dev, groff, libx11-dev, libxext-dev, libxpm-dev, libsigsegv-dev (>= 2.4-1), libreadline6-dev, libffcall1-dev, libdb-dev

and

Build-Depends: debhelper (>> 7), gettext, bison, libncurses5-dev, groff, libx11-dev, libxext-dev, libxpm-dev, libsigsegv-dev (>= 2.4), libreadline5-dev, dh-lisp (>= 0.3), libdb4.8-dev, libffcall1-dev

also look exceedingly dumb and kind of suspicious. I think they just had a dumb Build-Depends line and copied that into their Depends line for their -dev package, which is almost an understandable mistake.

 DebianBug:177057, which has blocked this bug for about two years (and is itself seven years old), indicates that some guy is redoing the packaging from scratch as of three days ago to make it less dumb in several ways. It looks like he has some questions on how to do this; we should help him out.

Then we should see about getting a freeze exception for Maverick (although it should go fine into Natty, and we don't really care about thirdparty on Maverick, arguably) on the grounds that clisp-dev is effectively unusable because of its libreadline5-dev dependency, and attempt to get a SRU for Lucid on the same grounds, though that might be harder. If we really want clisp-dev on Lucid, it might be easier to just get a debdiff against the current package to make the runtime dependencies less dumb.

Change History

comment:1 Changed 11 years ago by geofft

I think the upstream maintainer just said

note that the separate clisp-dev package does not make any sense.

on the bug report. So, should we depend on something else?

comment:2 Changed 11 years ago by jdreed

I assert that the number of people who want clisp-dev is small enough that we can just punt it from -thirdparty.

comment:3 Changed 11 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to ignored

We punted this 8 months ago, and nobody noticed or cared.

comment:4 Changed 11 years ago by jdreed

Also,  DebianBug:177057 was closed in October and fixed in 1:2.49-1, although that never made it into Natty. I still don't think we care.

Note: See TracTickets for help on using tickets.