Ticket #767 (closed defect: wontfix)

Opened 11 years ago

Last modified 11 years ago

dh_listpackages "fatal error" while generating debian/control with CDBS

Reported by: kaduk Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Or so says geofft during debathena-trainees.
Perhaps we should care?

Change History

comment:1 Changed 11 years ago by kaduk

This was during running dasource, I should mention

comment:2 Changed 11 years ago by geofft

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from [cdbs] will be a fatal error in future releases to dh_listpackages "fatal error" while generating debian/control with CDBS

The issue is the "fatal" error

dh_listpackages: cannot read debian/control: No such file or directory

dh_listpackages: warning: unknown options will be a fatal error in a future debhelper release
dh_listpackages: cannot read debian/control: No such file or directory

caused by running dh_listpackages -s or -i if no debian/control exists, as part of CDBS setting variables while running debian/rules (which we're running in order to generate debian/control), but this runs within a $(shell) block and doesn't do anything useful anyway, and a non-zero exit from $(shell) isn't a problem. Arguably CDBS should do clever things to make the debian/control target not set these variables and suppress all of the spew (there's a couple of failed greps, too), but that isn't pressing, and just sounds like a bunch of painful Makefile hacking.

Note: See TracTickets for help on using tickets.