Ticket #868 (new defect)

Opened 10 years ago

Last modified 10 years ago

deal better with overly fancy PDFs

Reported by: geofft Owned by:
Priority: low Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Since cluster machines have Adobe Reader installed, it would be nice if attempts to view and/or print PDFs that require Adobe Reader could direct the user to run the version of Reader already on the system, instead of downloading the latest version from the website and attempting to install it.

As an example, consider the CS  transfer credit form, which in any viewer other than Adobe Reader (such as  in Google Docs Viewer) gives you a message about downloading the latest version of Reader.

I'm not really sure what to do here or if it's possible to deal with this better, but I figured I'd at least report the UX bug since a user did get confused by it.

Change History

comment:1 Changed 10 years ago by davidben

While I have not looked a the PDF in question closely, this message is likely burned into the PDF in question as a fallback for readers which do not support some PDF feature or another. It's not a string in the reader. You'd want to either fix libpoppler to implement PDF better, or go back to getting people to use Adobe Reader; libpoppler is lacking in several places.

Note: See TracTickets for help on using tickets.