Ticket #899 (closed defect: worksforme)

Opened 10 years ago

Last modified 9 years ago

regapplet text is borked

Reported by: jdreed Owned by:
Priority: low Milestone: Precise Beta
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

See  bugs:27557 for a full description, but basically text is truncated halfway through the second line in the Reg Applet.

I don't think this is related to #650. However, it's possible that we're losing because the window is getting painted with textsize calculated for a single line of text (the initial value in TextBlock?). And it works in appletviewer, so this will be hard to debug.

It's possible that the actual subject of this ticket should be "Someone should make the Reg Applet not use ca.-1996 Java code."

Change History

comment:1 Changed 10 years ago by jdreed

Laura also notes that this doesn't work in the FF kiosk browser, visiting  http://web.mit.edu/register/ directly

comment:2 Changed 10 years ago by jdreed

Possible stupid solution: Use java locker's appletviewer to run the regapplet from kiosk.

comment:3 Changed 9 years ago by jdreed

  • Status changed from new to closed
  • Resolution set to worksforme

I can't repro this, and Laura said she hasn't seen it in a while. We can re-open if it's actually reproducible.

Note: See TracTickets for help on using tickets.