Ticket #933 (new enhancement)

Opened 10 years ago

Last modified 9 years ago

Update libraries to support multiarch

Reported by: geofft Owned by:
Priority: normal Milestone: The Distant Future
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

Following the  Ubuntu multiarch spec, for releases that support multiarch we should update the paths that our libraries install into, and add a Multi-Arch: field to control, for all our libraries. See also  Debian's multiarch page.

(We may want to split this into separate tickets, depending on how hard this is for various libraries?)

Change History

comment:1 Changed 10 years ago by andersk

Since we use CDBS, we’ll also need to  disable dh-buildinfo because of  DebianBug:620104.

comment:2 Changed 9 years ago by jdreed

The Debian Bug is fixed in wheezy and quantal. Beyond that, I haven't really thought much more about this and don't feel like wrapping my head around multiarch before this summer. It sounds like we'll still lose on Lucid and Squeeze, right?

Note: See TracTickets for help on using tickets.