Timeline
01/19/90:
- 00:32 Changeset [2623] by
- Initial revision
- 00:14 Changeset [2622] by
- If environment variable OLCD_PORT is set, it overrides the /etc/services entry.
01/18/90:
- 23:17 Changeset [2621] by
- Re-indented. Made control arguments more readable; added -port to explicitly request a port number. Append port number to "ME" if supplied. Removed syslog initialization, since it is done elsewhere. Close all file descriptors, not just first ten. Also, be more paranoid about fd numbers returned.
- 22:03 Changeset [2620] by
- Added PID to syslog messages.
- 04:19 Changeset [2619] by
- update to ZWGC0_3_12
- 04:18 Changeset [2618] by
- fix array index bug when using @center(), @left(), @right()
01/17/90:
- 23:59 Changeset [2617] by
- put in a couple of casts to satisfy prototypes
- 11:40 Changeset [2616] by
- document mail,popret in comments
- 00:45 Changeset [2615] by
- Changed constant names in variable sizes to new names. Also added a few newlines, and changed sprintf to strcpy where appropriate.
- 00:45 Changeset [2614] by
- Changed constant names in variable sizes to new names.
- 00:43 Changeset [2613] by
- Changed constant names in variable sizes to new names. Also uncase'd hostname and daemon_host_entry->h_name. This was causing problems at start up, because the daemon thought that "fries" != "FRIES"...
- 00:42 Changeset [2612] by
- Changed constant names in variable sizes to new names. Also added newlines at the end of many messages.
- 00:41 Changeset [2611] by
- oops. undid a name change that shouldn't have been done...
- 00:40 Changeset [2610] by
- Changed constant names in variable sizes to new names. Also added external declaration of errno.
- 00:23 Changeset [2609] by
- Changed constant name in variable declaration to new name.
- 00:16 Changeset [2608] by
- added struct for PRINCIPAL. first attempt -- not used anywhere -- but we will eventually need something like it. also changed constants used in defining sizes of some variables to new constant names...
- 00:15 Changeset [2607] by
- added "struct tREQUEST" to header file.
- 00:14 Changeset [2606] by
- added Pfunction type... changed Command structure to use it instead of FUNCTION.
01/16/90:
- 22:29 Changeset [2605] by
- Phased out old constants from source tree. No longer needed, so deleted.
- 22:24 Changeset [2604] by
- Changed name of constant from BUFSIZE to BUF_SIZE to match new define's.
- 22:23 Changeset [2603] by
- added some return types to function declarations, and a cast.
- 22:19 Changeset [2602] by
- Changed names of some constants in declarations of sizes of variables.
- 22:13 Changeset [2601] by
- Changed names of some constants in declarations of sizes of variables.
- 21:54 Changeset [2600] by
- Changed names of some constants in declarations of sizes of variables.
- 21:40 Changeset [2599] by
- Changed names of some constants in declarations of sizes of variables.
- 09:38 Changeset [2598] by
- added new flag "-nofork" to tell daemon not to fork when starting up. also changed spacing of a few comments...
- 06:37 Changeset [2597] by
- Fixed a bug: when changing instance, a t_who was done. However, the instance in the Request struct was not changed to reflect the new instance just changed to, and so t_who was reporting who you were just connected to (the old instance number was left in the request struct).
- 06:35 Changeset [2596] by
- check for existance of log file before appending. also create and use new function vfmt().
- 06:27 Changeset [2595] by
- reorganized some declarations; added `const' for arg of log_admin
- 06:08 Changeset [2594] by
- Fixed up function declarations.
- 03:19 Changeset [2593] by
- removed some unused variables; used log_to_syslogd rather than syslog; added log_debug (in similar vein to existing fcns)
- 00:46 Changeset [2592] by
- Added old-style definition headers; made Zephyr class be "OLZ" if OLZ is defined and TEST isn't.
- 00:32 Changeset [2591] by
- Changed SYSLOG_LEVEL to use a real, existing facility. Also added declaration for errno.
- 00:31 Changeset [2590] by
- Added new file syslog.{c,o}; added new macro NoGCC which forces use of /bin/cc; made UseCPlusPlus not default; replaced -DTEST and -DOLZ with -DSYSLOG.
- 00:27 Changeset [2589] by
- put in explicit return types; commented out a couple of unused functions.
01/15/90:
- 23:47 Changeset [2588] by
- Removed system-log functions and variables.
- 23:44 Changeset [2587] by
- [vanharen] expand old-style header of log_log to look prettier.
- 23:41 Changeset [2586] by
- Initial revision
- 22:04 Changeset [2585] by
- Added check for OLCD_HOST environment variable, overriding Hesiod. Also, nemesis.mit.edu is used only if OLZ isn't defined.
- 21:53 Changeset [2584] by
- *** empty log message ***
01/12/90:
- 16:04 Changeset [2583] by
- changed ifdef to OLZ for pointing logs to fries, as it may be useful to compile with TEST and not with OLZ, and run on matisse...
01/10/90:
- 23:11 Changeset [2582] by
- a little bit of new debugging information
- 22:47 Changeset [2581] by
- changed #ifdef DEBUG to #ifdef MALLOC_DEBUG
- 16:37 Changeset [2580] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 16:23 Changeset [2579] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 12:11 Changeset [2578] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 11:55 Changeset [2577] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 10:58 Changeset [2576] by
- need to process input after the XSync's in order to make sure we get all the events and process them in a timely manner.
- 10:57 Changeset [2575] by
- 0.3.11: fix bug with reverse stack and non-drawing windows
- 10:12 Changeset [2574] by
- Added needed declarations for non-ANSI C.
- 10:11 Changeset [2573] by
- more "#if __STDC__" code
- 10:10 Changeset [2572] by
- added more "#if __STDC__" code; moved rcsid to after inclusion of olc header files
- 09:19 Changeset [2571] by
- Added `const' where needed.
- 09:05 Changeset [2570]
- This commit was manufactured by cvs2svn to create tag 'ZSRV3PT20'.
- 09:05 Changeset [2569] by
- code to flush subs for bad entries (for compatibility with older servers)
- 08:53 Changeset [2568] by
- added `const' where applicable; added missing argument to olc_broadcast_message; conditionalized new-style function headers as a temporary measure
- 08:49 Changeset [2567] by
- conditionalized new-style function headers on __STDC__ as a temporary measure.
- 07:54 Changeset [2566] by
- update vno adding BADSUBPORT support
- 07:54 Changeset [2565] by
- add BADSUBPORT support
- 07:23 Changeset [2564] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 06:43 Changeset [2563] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 06:38 Changeset [2562] by
- 1) fix fencepost error in array sizing 2) make sure the right port number is used for dumping (just in case... doesn't seem to make a difference, but might explain the xmit xmit failures to port #0)
- 06:38 Changeset [2561] by
- add BADSUBPORT support
- 06:30 Changeset [2560] by
- Added `const' where appropriate. Also added old-style function headers as temporary compatibility measure.
- 06:13 Changeset [2559] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 05:28 Changeset [2558] by
- added ifdef's on STDC around prototypes, and added back old-style prototypes, so we can compile with pcc.
01/09/90:
- 12:26 Changeset [2557] by
- add ZSRV_BADSUBPORT
- 11:08 Changeset [2556] by
- added ifdef's on STDC around declarations, and added back old-style declarations, so we can compile with pcc.
- 11:03 Changeset [2555] by
- added declarations for realloc (both STDC and old-style C)
01/08/90:
- 07:00 Changeset [2554] by
- Athena-specific version (.startup.tty)
01/05/90:
- 01:55 Changeset [2553] by
- "protoized" version; also dropped some declarations that were moved to olc/os.h.
- 01:23 Changeset [2552] by
- "protoized" version; also added/changed declarations in minor ways as needed. added missing arguments commented with "/*???*/" in a couple of places.
- 01:13 Changeset [2551] by
- added prototype to definition of type "FUNCTION"
- 01:12 Changeset [2550] by
- C++ related changes
01/04/90:
- 09:59 Changeset [2549] by
- simplified C++ rule
- 09:46 Changeset [2548] by
- added prototypes for hesiod routines
- 09:38 Changeset [2547] by
- Initial revision
- 09:38 Changeset [2546] by
- Added prototypes for some functions.
- 09:37 Changeset [2545] by
- a bit of rearrangement for ANSI C and C++
- 09:37 Changeset [2544] by
- changed definition of type "FUNCTION"
- 08:54 Changeset [2543] by
- removed gethostbyname declaration (moved to olcd.h)
01/03/90:
- 18:46 Changeset [2542] by
- type corrections
- 18:44 Changeset [2541] by
- type correction
- 18:42 Changeset [2540] by
- type corrections and static declarations added
- 18:40 Changeset [2539] by
- moved inclusion of olc-specific header files to after system header files
- 18:39 Changeset [2538] by
- type corrections
- 18:37 Changeset [2537] by
- added return types and static function declarations
- 18:36 Changeset [2536] by
- fixed up typecast of null to use correct type
- 18:33 Changeset [2535] by
- Added lots of declarations, many of which should be elsewhere.
- 18:30 Changeset [2534] by
- various corrections from type-checking
- 18:26 Changeset [2533] by
- Various standard-C changes: Added `const' in some places, added needed declarations, added `void' where warranted.
- 18:24 Changeset [2532] by
- RCS headers and changes to permit building as C++.
01/02/90:
- 12:53 Changeset [2531] by
- changed description of case ... match ... endcase statement to correctly reflect that the compare is case-insensitive.
- 08:35 Changeset [2530]
- This commit was manufactured by cvs2svn to create tag 'PATCH9'.
- 08:35 Changeset [2529]
- This commit was manufactured by cvs2svn to create tag 'PATCH8'.
- 08:35 Changeset [2528]
- This commit was manufactured by cvs2svn to create tag 'ASR7PT0_SNAP0'.
- 08:35 Changeset [2527] by
- change $Header$ to $Id$
12/30/89:
- 14:48 Changeset [2526] by
- Changed an = to an == Author: jtkohl Auditor: qjb
12/28/89:
- 13:13 Changeset [2525] by
- C++ changes
- 11:10 Changeset [2524] by
- For AFS homedirs that are not world readable, use users uid for access check.
- 10:26 Changeset [2523] by
- Initial revision
- 10:24 Changeset [2522] by
- Use current directory for olcd.h rather than ../include.
- 10:22 Changeset [2521] by
- make `depend' dependent on `Makefile', which in turn depends now on Imakefile and the configuration files. also, use concat() instead of /**/ in a couple of places.
- 10:06 Changeset [2520] by
- Initial revision
- 09:45 Changeset [2519] by
- added check to make sure that purge is called with no arguments.
- 09:44 Changeset [2518] by
- Added error PURGE_TOO_MANY_ARGS ,
12/22/89:
- 12:14 Changeset [2517] by
- *** empty log message ***
- 12:06 Changeset [2516] by
- *** empty log message ***
- 11:37 Changeset [2515] by
- *** empty log message ***
- 11:27 Changeset [2514] by
- changed logging of descriptions to use "log_description" function instead of "log_comment".
- 11:26 Changeset [2513] by
- added ifdef on OLZ for building clients that look for that service instead of OLC.
- 11:25 Changeset [2512] by
- added instances to many printed messages. Added "log_description" function for inserting description changes into logs.
- 11:20 Changeset [2511] by
- changed "was_connected" function to compare uids, updated "connect_knuckles" function to use it and update the list of uids. Also changed "match_maker" to use it. It is broken, however, because all uid's are being set to 0, for some reason... haven't yet tracked down that bug. The mechanism should probably be changed to use kerberos principals instead, anyway...
- 11:19 Changeset [2510] by
- changed test host to FRIES instead of picasso for "notefiles" storage.
- 11:03 Changeset [2509] by
- Added ifdef on OLZ for building clients that look for that service instead of OLC.
- 10:03 Changeset [2508] by
- Initial revision
- 09:41 Changeset [2507] by
- fix line-length problem with case ... endcase
12/21/89:
- 11:52 Changeset [2506] by
- Added "ME" define with name of daemon; removed "debug" variable (for old Kerberos code); make wrong-host be fatal when not built for testing; get Kerberos tickets at startup; removed some debugging printouts; use K_INSTANCEbuf instead of K_INSTANCE when getting tickets; don't automatically return (without doing anything) from get_kerberos_ticket.
- 07:08 Changeset [2505] by
- Changed kerberos function call to new name.
Note: See TracTimeline
for information about the timeline view.