Changes between Version 4 and Version 5 of GettingStartedWithDevelopment


Ignore:
Timestamp:
01/19/11 07:35:49 (11 years ago)
Author:
geofft
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • GettingStartedWithDevelopment

    v4 v5  
    1 Before beginning development, you should have a workstation (or VM) with Debathena installed.  Unless you have a strong preference, we recommend starting with the highest version of Ubuntu supported by Debathena.  As of January 2011, this is Ubuntu 10.04 (Lucid).  I 
     1Before beginning development, you should have a workstation (or VM) with Debathena installed.  Unless you have a strong preference, we recommend starting with the highest version of Ubuntu supported by Debathena.  As of January 2011, this is Ubuntu 10.04 (Lucid). The instructions henceforth assume that you are using the newest Debathena packages, and a base distribution (Debian or Ubuntu) from at least 2008. 
    22 
    33You should install at least the debathena-standard metapackage.  You should also install the debathena-debian-dev package, which installs a number of packages required for building Debian packages. 
     
    55You should also create the file ~/.devscripts with the following contents: 
    66{{{ 
    7 DEBUILD_DPKG_BUILDPACKAGE_OPS="-us -uc -sa -i -I.svn" 
     7DEBUILD_DPKG_BUILDPACKAGE_OPS="-us -uc -sa -i -I" 
    88DEBEMAIL="yourusername@mit.edu" 
    99DEBFULLNAME="Your Full Name"