source: trunk/debathena/config/afs-config/debian/debathena-afs-config.postinst @ 22707

Revision 22707, 998 bytes checked in by tabbott, 16 years ago (diff)
In afs-config: * Restart AFS so AFS comes up correctly at installation, but don't let installation fail if AFS can't restart because it was already running.
Line 
1#!/bin/sh
2# postinst script for debathena-afs-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21#DEBHELPER#
22
23case "$1" in
24    configure)
25        if hash invoke-rc.d; then
26            invoke-rc.d openafs-client restart || true
27        else
28            /etc/init.d/openafs-client restart || true
29        fi
30    ;;
31
32    abort-upgrade|abort-remove|abort-deconfigure)
33    ;;
34
35    *)
36        echo "postinst called with unknown argument \`$1'" >&2
37        exit 1
38    ;;
39esac
40
41exit 0
Note: See TracBrowser for help on using the repository browser.