source: trunk/debathena/config/apparmor-config/debian/debathena-apparmor-config.postinst @ 24709

Revision 24709, 1.1 KB checked in by broder, 14 years ago (diff)
In apparmor-config: * Run debhelper- and config-package-dev-generated postinst/postrm code before reloading apparmor, so the diversions are actually in place when we do.
Line 
1#!/bin/sh
2# postinst script for debathena-apparmor-config
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20# dh_installdeb will replace this with shell code automatically
21# generated by other debhelper scripts.
22
23#DEBHELPER#
24
25case "$1" in
26    configure)
27        if hash apparmor_status 2>/dev/null && apparmor_status --enabled; then
28            if hash invoke-rc.d 2>/dev/null; then
29                invoke-rc.d apparmor reload
30            else
31                /etc/init.d/apparmor reload
32            fi
33        fi
34    ;;
35
36    abort-upgrade|abort-remove|abort-deconfigure)
37    ;;
38
39    *)
40        echo "postinst called with unknown argument \`$1'" >&2
41        exit 1
42    ;;
43esac
44
45exit 0
Note: See TracBrowser for help on using the repository browser.