source: trunk/debathena/config/apparmor-config/debian/rules @ 24714

Revision 24714, 1.6 KB checked in by broder, 14 years ago (diff)
In apparmor-config: * Include AFS homedirs in the list of home directories. (Trac: #601)
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4ifneq ($(wildcard /etc/apparmor.d/abstractions/kerberosclient),)
5    DEB_TRANSFORM_FILES_debathena-apparmor-config += /etc/apparmor.d/abstractions/kerberosclient.debathena
6endif
7
8ifneq ($(wildcard /etc/apparmor.d/abstractions/cups-client),)
9    DEB_TRANSFORM_FILES_debathena-apparmor-config += /etc/apparmor.d/abstractions/cups-client.debathena
10endif
11
12ifneq ($(wildcard /etc/apparmor.d/abstractions/X),)
13    DEB_TRANSFORM_FILES_debathena-apparmor-config += /etc/apparmor.d/abstractions/X
14endif
15
16ifneq ($(wildcard /etc/apparmor.d/tunables/home),)
17    ifeq ($(wildcard /etc/apparmor.d/tunables/home.d),)
18        # Needed for anything older than Lucid
19        DEB_TRANSFORM_FILES_debathena-apparmor-config += /etc/apparmor.d/tunables/home
20    endif
21endif
22
23ifneq ($(wildcard /etc/apparmor.d/usr.sbin.cupsd),)
24    DEB_REMOVE_FILES_debathena-apparmor-config += /etc/apparmor.d/usr.sbin.cupsd
25endif
26
27include /usr/share/cdbs/1/rules/debhelper.mk
28include /usr/share/cdbs/1/rules/config-package.mk
29
30ifneq ($(wildcard /etc/apparmor.d/usr.sbin.cupsd),)
31    common-build-indep:: debian/usr.sbin.cupsd.debathena
32    debian/usr.sbin.cupsd.debathena: $(call debian_check_files,/etc/apparmor.d/usr.sbin.cupsd)
33        debian/transform_usr.sbin.cupsd.debathena < $< > $@
34    clean::
35        -rm debian/usr.sbin.cupsd.debathena
36    install/debathena-apparmor-config::
37        dh_install debian/usr.sbin.cupsd.debathena etc/apparmor.d
38endif
39
40ifneq ($(wildcard /etc/apparmor.d/tunables/home.d),)
41    install/debathena-apparmor-config::
42        install -D -m 644 debian/home \
43            $(DEB_DESTDIR)/etc/apparmor.d/tunables/home.d/debathena
44endif
Note: See TracBrowser for help on using the repository browser.