source: trunk/debathena/config/cluster-login-config/debian/rules @ 24420

Revision 24420, 1.6 KB checked in by broder, 14 years ago (diff)
In cluster-login-config: * Kill kexec with fire - we'll enable it by hand from reactivate (Trac: #536). In reactivate: * Manually enable kexec on logout-triggered reboots. (Trac: #536)
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3GDM_VERSION = $(shell dpkg-query --showformat='$${Version}' --show gdm)
4NEW_GDM = $(shell dpkg --compare-versions $(GDM_VERSION) ge '2.25.2~' && echo y)
5EVENT_D = $(shell test -f /etc/event.d/tty1 && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8ifneq ($(wildcard /etc/gdm/gdm.conf-custom.debathena),)
9    GDM_CONFFILE = /etc/gdm/gdm.conf-custom.debathena.debathena
10else
11    GDM_CONFFILE = /etc/gdm/gdm.conf.debathena.debathena
12endif
13DEB_UNDIVERT_FILES_debathena-cluster-login-config += \
14        /etc/default/kexec.debathena
15DEB_UNDIVERT_VERSION_/etc/default/kexec.debathena = 1.23~
16
17ifneq ($(NEW_GDM),y)
18    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
19        ${GDM_CONFFILE}
20else
21    DEB_REMOVE_FILES_debathena-cluster-login-config += \
22        /usr/share/xsessions/gnome-failsafe.desktop \
23        /usr/share/xsessions/xterm.desktop
24endif
25
26DEB_REMOVE_FILES_debathena-cluster-login-config += \
27    /usr/lib/indicator-session/indicator-users-service
28
29ifeq ($(EVENT_D),y)
30    DEB_REMOVE_FILES_debathena-cluster-login-config += \
31        /etc/event.d/tty1 \
32        /etc/event.d/tty2 \
33        /etc/event.d/tty3 \
34        /etc/event.d/tty4 \
35        /etc/event.d/tty5 \
36        /etc/event.d/tty6
37else
38    DEB_REMOVE_FILES_debathena-cluster-login-config += \
39        /etc/init/tty1.conf \
40        /etc/init/tty2.conf \
41        /etc/init/tty3.conf \
42        /etc/init/tty4.conf \
43        /etc/init/tty5.conf \
44        /etc/init/tty6.conf
45endif   
46include /usr/share/cdbs/1/rules/debhelper.mk
47include /usr/share/cdbs/1/rules/config-package.mk
48
49install/debathena-cluster-login-config::
50        if [ "$(EVENT_D)" = "y" ]; then \
51                dh_install debian/ttymsg etc/event.d; \
52        else \
53                dh_installinit --name=ttymsg -n --upstart-only; \
54        fi
Note: See TracBrowser for help on using the repository browser.